[SOLVED] Sound muted on plugging headphones

Hi guys,

Just installed Netrunner 15 on my laptop and as always it looks great, but I’m having some issues with it and theres one I can’t find to fix.

When I plug in headphones into the laptop jack, sound gets muted and I need to go to Sound and Video settings and manually change the sound output to Headphones. Then, if I unplug the headphones, sound gets muted on the speakers and I need to go the same way and change it manually.
This was not happening in Netrunner 14.1 where sound changing output was working fine.

Anyone knows how to fix this?

It could be a problem with pulseaudio or the alsa drivers. Do you have any switches for automute in alsamixer when executed via terminal like so

alsamixer -c0

If yes try disabling them and see if this works.

Also can you post the exact soundcard chip/device you are using
lspci -v | grep -i audio might help here as a command.

Well thanks a lot! I fixed the problem, but not exactly where you indicated.

In fact there was a setting in Alsamixer that needed to be enabled, Loopback. Auto-mute was enabled indeed but disabling it breaks it even more.
So now I enabled Loopback, set the sound to Headphones and now it changes between phones and speakers correctly.

Thanks for the help and let’s see if I can fix all the other issues I am having.

By disabling automute in alsamixer your going to have audio coming from all of your outputs all the time, if this is OK with you then great. However, if you would rather have pulse-audio automatically switch between headphones and speaker and mute the one not in use as you plug in and out your headphones then undo that change and do this instead:

Using sudo edit the /etc/pulse/default.pa file and remove the # from the load-module module-switch-on-port-available line, now save the file and you should be good.

Thanks for that tip.

As I said, enabling Loopback in Alsamixer fixed the issue. I left Auto-mute enabled as it was by default. If I ever need to edit the Pulseaudio file I now know where it should be.

and how to save the file ?

Alsamixer normally saves things automatically upon exit.
But if you specifically want to save the alsa config you can execute sudo alsactl store

ok i saved some how /etc/pulse/default.pa file now everything works
thank you!
and as for sound options cannot find any of them no idea where why are, but dont need anymore.

Thanks! Editing the /etc/pulse/default.pa worked for me, just had to run pulseaudio -k to restart pulse audio for effects to go into place. A reboot would have done the same, I think.