[Solved]Steam freezing on bootup

Hi guys and gals,

Every time I try and start steam since last night, it is frozen. The icon looks a bit different and the only thing that I think has changed is that it says 0 of 1 or 1 of 1 downloading. I can’t click on anything or do anything. It does keep my friends current at bootup. Every time I boot up it shows who is currently online of my friends, like a snapshot and then it freezes also.

I have tried updating from pacman and that has not helped. I tried removing the packages and reinstalling and that hasn’t done anything either. if you have any ideas let me know!


Are you trying to launch steam using the steam-runtime or just the standard steam shortcut?
Also have you installed the latest Manjaro update pack 6? http://forums.netrunner-os.com/showthread.php?tid=16088
sudo pacman -Syyu

If that fails to resolve your issue then try these:

Make sure KDE is using openGL for composting:
In system settings, go to “Desktop Effects” in the “Workspace Appearance and Behaviour” section. Open the “Advanced” tab. Change “Compositing type” from XRender to OpenGL.

Or add the following line to your /etc/hosts file:           yourhostname

I will continue looking into it, no one else has yet to report this issue. Could you try opening steam from the command line and post the output when it freezes?

1- I have tried using both Steam options. The standard Steam is the one that freezes. the Steam(steam runtime) runs fine and does not have this problem, but it has another problem I had earlier. It gives me this error

"OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457."

Maybe I could try and fix this issue again?

2- I am up to date.

3- The Compositing type was and is on OpenGL.

when I type in steam in the terminal, this is the command that keeps repeating.

/home/ben/.local/share/Steam/ubuntu12_32/steamwebhelper: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory


Make sure gconf is installed on your system, if it is then you could try installing lib32-gconf from the AUR and see if that fixes it.

Do you have the 32bit utils and opencl packages for your video card driver installed?
This is what fixed the issue on my gaming system with the steam-native package throwing this message:
OpenGL GLX context is not using direct rendering, which may cause performance problems.

I just looked and gconf is installed. I reinstalled, checked and nothing. Then I removed it completely and ithen nstalled it–still getting the same process. I might removed it by mistake, but I think I played it one night and booted it up the next and it just didn’t work. I don’t really mess with the computer unless something isn’t working. I also did not update before this problem started.

Edit: Ok, about to go to dinner with some friends. I will play with it more when I get back.

Edit 2: The only packages I could see that I thought would be relevant were the lib32-catalyst-utils. I checked and I didn’t have the catalyst driver installed. I installed them, and installed the the lib32-catalyst-utils. it gave me the OpenGL error. Then, I installed the lib32-opencl-catalyst packages. I still got the error OpenGL error.

Edit 3: It must have been one of the suggestions above that I thought didn’t work. A bit confused here. I wish I could retrace for future help, but I am not sure which one of those suggestions actaully fixed the problem. BUT Steam(steam runtime) is officially working! I think this has been super fortunate problem as well because now Dota 2 actaully runs much, much smoother!

Thank you so much for the help!

I had edited my second post, while you we’re posting, please have another look.