[SOLVED] Tor v0.2.3.25: Failed to bind one of the listener ports

[quote]авг 02 10:42:57.508 [Notice] Tor v0.2.3.25 (git-3fed5eb096d2d187) running on Linux.
авг 02 10:42:57.508 [Notice] Tor can’t help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
авг 02 10:42:57.508 [Notice] Read configuration file “/home/g/.vidalia/torrc”.
авг 02 10:42:57.508 [Notice] Initialized libevent version 2.0.19-stable using method epoll (with changelist). Good.
авг 02 10:42:57.508 [Notice] Opening Socks listener on
авг 02 10:42:57.508 [Notice] Opening Control listener on
авг 02 10:42:57.509 [Notice] This version of OpenSSL has a known-good EVP counter-mode implementation. Using it.
авг 02 10:42:58.091 [Notice] OpenSSL OpenSSL 1.0.1c 10 May 2012 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
авг 02 10:42:58.092 [Notice] Reloaded microdescriptor cache. Found 4071 descriptors.
авг 02 10:42:58.092 [Notice] We now have enough directory information to build circuits.
авг 02 10:42:58.092 [Notice] Bootstrapped 80%: Connecting to the Tor network.
авг 02 10:42:58.092 [Notice] New control connection opened.
авг 02 10:42:58.820 [Notice] Heartbeat: Tor’s uptime is 0:00 hours, with 1 circuits open. I’ve sent 0 kB and received 0 kB.
авг 02 10:42:59.318 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
авг 02 10:43:00.738 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
авг 02 10:43:02.540 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
авг 02 10:43:02.540 [Notice] Bootstrapped 100%: Done.
авг 02 10:43:29.688 [Notice] Opening Socks listener on
авг 02 10:43:29.688 [Warning] Could not bind to [color=#FF0000]Address already in use[/color]. Is Tor already running?
авг 02 10:43:29.689 [Notice] Closing no-longer-configured Socks listener on
авг 02 10:43:29.689 [Warning] Controller gave us config lines that didn’t validate: [color=#FF0000]Failed to bind one of the listener ports[/color].[/quote]

[quote]# This file was generated by Tor; if you edit it, comments will not be preserved

The old torrc file was renamed to torrc.orig.1 or similar, and Tor will ignore it

ControlPort 9051
DataDirectory /home/g/.tor
DirReqStatistics 0
Log notice stdout
SocksPort 9150
P.S. Netrunner’s default configuration, latest version, and only Tor was installed via apt-get. Thanks!

Have you checked that tor is not already running or if any other application is using the port 9050 ?

No, Tor was run once. How to check whether some other application is using port 9050? Thank in advance.

You can check this with netstat

It helped, thanks. It was the Tor daemon already running while vidalia tried to start another instance.