Netrunner Home

[solved] Unable to boot into Netrunner 19 with encrypted partitions


#1

I am using a dual boot environment with Windows 10 and netrunner 19 desktop Debian: I created the following partitions(ext4): /home. encrypted, /root. encrypted, Swap: encrypted, /boot. encrypted and modified the configuration file of Calamares at line 37(after VirtualBox) with - initramfs (as mentioned in another post). The installation was successfully and after rebooting the system starts but it hangs with a command prompt initramfs and nothing goes on. What goes wrong here? What I can do?

Thank you.


#2

Seems like initrd is broken.
Can you try chrooting into the installed system and update initramfs.

update-initramfs -u
is the command you need to use.
As you have a separate /boot and / you need to mount both.

Would be nice to know if that fixes the issue you have.


#3

I have solved this issue with the following partitions scheme: /root (ext4) luks, /home(ext4) luks, Swap luks. I added the -initramfs in line 37 to the calamares configuration file and all works fine now. Thank you for your help.


#4

Thanks for reporting back.
So the initial issue might be because of the separate /boot partition. Noted that.