(SOLVED) Unistalled program still showing up

I just uninstalled Qmmp from my Netrunner 14.1 by doing a purge on it, but is still shows up in homerun kickoff menu and with Alt+F2. If I try to run it tells me it does not exist.

How can I fully remove Qmmp entry from the menu (or any other application with this issue)?

Make sure that all of it’s .desktop files were deleted:

Log out and back in.

I don’t have any of those files in my system. I actually had a qmmp folder inside usr/share, I deleted it but I still got a qmmp entry in homerun kickoff and by searching with Alt-F2, however the entry does not have an icon.

This might just be a refresh issue, have you tried logging out and back in yet?

Yes I did, I also rebooted the system and qmmp is still there. The fact that it came preinstalled in the system maybe the answer for this issue.
I searched for any files named qmmp in my system but it found nothing.

OK then, did you look here?
{home dir} ./local/share/applications
or here:
{home dir} ./gnome/apps

Oh, thanks a lot!
There were two nasty qmmp files inside ./local/share/applications. I deleted them and now qmmp is gone from the system.
This may be a bug with pre installed apps prorably, but I will take a look at other pre installed apps and see how they behave when purged.
Thanks for your time.

EDIT: Yes I can confirm this is happening with all apps that came pre installed with Netrunner. When I remove/purge them, I need to go to /.local/share/applications and remove their .dektop files to remove them from showing up in the system. Apps that I installed myself do not have this issue and are removed correctly.

Actually, I think certain applications make special launchers there that they use for something.

When I installed google-chrome and ran it for the first time it put these default web apps in that location.

Ass you can see, those are the added web apps from the apps tab of Chrome.

Yes Chrome does add those lauchers, but if you purge Chrome, it removes all of them. I can’t see why are the default apps not uninstalling completely. It is a system bug for sure.

Yes, but I think the difference is that chrome came with those files in it’s package, the others were probably created by the application itself. There would be no way for pacman to know about files created either manually or by an application after installation. Pacman will also not remove anything edited or changed after installation either, this is the reason why pacman creates .pacsave, .pacnew, and .pacorig files. https://wiki.archlinux.org/index.php/Pacnew_and_Pacsave_files