(Solved) usb-creator broken (apparently)

Tried to run usb-creator (both gtk and kde)
gtk would open, but would do nothing after choosing an iso.

kde wouldn’t even open…got error:

Traceback (most recent call last): File "/usr/bin/usb-creator-kde", line 26, in <module> from PyKDE4.kdecore import KCmdLineArgs, KCmdLineOptions, ki18n ImportError: No module named 'PyKDE4'
From a comment here https://aur.archlinux.org/packages/usb-creator I installed “kdebindings-python” and usb-creator-kde would finally open, but it had same behavior as usb-creator-gtk: would do nothing after choosing an iso.

I installed imagewriter (SUSE Studio Imagewriter) and that seems to work.

Netrunner Rolling (Manjaro) comes pre-installed with SUSE Studio Imagewriter.

There is also the Manjaro developed usbiso package in the community repository.

Note: The Netrunner Rolling (Manjaro) hybrid ISO’s are not compatible with usb-creator for the same reasons there not compatible with unetbootin and other similar utilities, just an FYI.

I just had to do a fresh install and SUSE imagewriter is not installed (see screenshot)

I found a “isousb”

Thanks for info on the usb-creator - I’ll avoid it!