(SOLVED) Wi-Fi and Broadband connections

I used Maui since inception on both desktop and laptop computers. Using an ‘USB Aircard’ (mobile broadband) connection or Wi-Fi was as easy as pie as all the relevant connection services were displayed in Network Connections together with a number of other network connections within close vicinity of my router.

It was not necessary to create a new connection as they were already displayed in the Networks window and needed only a click of the mouse to change.

The network connection manager in Netrunner 19.01 (Edit your Network Connections) does only display my wired connection and won’t sense/detect any other available Wi-Fi connections.

I read the post with a similar issue https://support.blue-systems.com/t/unable-to-connect-to-wifi-network-in-live-session/4197/11 but am unsure if the “Solution That Worked” in the last message of this post is applicable to Netrunner 19.01.

I kindly request guidance to edit my network connections accordingly. Thanks

It seems that either your wifi chip was not detected or the firmware for it is missing.
Best to find out is running
inxi -v4
and see what it lists as network devices. If your Wireless Network device appears its a good sign as it detected the card in general.
Maybe you can post the output here and I will do a research to see if this Wifi Chip is going to work on Netrunner.
Usually it should when it was working fine on Maui before, so you only need the right firmware files which might be missing.

Here is the output of inxi -4:

karl@laptop:~$ inxi -v4
Host: laptop Kernel: 4.19.0-2-amd64 x86_64 bits: 64
compiler: gcc v: 8.2.0 Desktop: KDE Plasma 5.14.5
Distro: Netrunner 19.01 (Blackbird)
Type: Laptop System: TOSHIBA product: Satellite L745
v: PSK14L-012001 serial:
Mobo: Intel model: N/A serial:
BIOS: INSYDE v: 1.80 date: 08/24/2011
ID-1: BAT1 charge: 31.9 Wh
condition: 31.9/55.0 Wh (58%)
model: Panasonic PA3817U-1BRS status: Full
Topology: Dual Core model: Intel Core i5-2430M bits: 64
type: MT MCP arch: Sandy Bridge rev: 7
L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 19157
Speed: 798 MHz min/max: 800/3000 MHz Core speeds (MHz):
1: 798 2: 798 3: 798 4: 800
Device-1: NVIDIA GF108M [GeForce GT 525M]
vendor: Toshiba America Info Systems driver: nvidia
v: 390.87 bus ID: 01:00.0
Display: x11 server: X.Org 1.20.3 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa
resolution: 1366x768~60Hz
OpenGL: renderer: GeForce GT 525M/PCIe/SSE2
v: 4.6.0 NVIDIA 390.87 direct render: Yes
Device-1: Qualcomm Atheros AR9285 Wireless Network
vendor: Lite-On driver: ath9k v: kernel port: 3000
bus ID: 09:00.0
IF: wlp9s0 state: down mac: 36:b4:47:31:64:37
Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
vendor: Toshiba America Info Systems driver: atl1c
v: port: 2000 bus ID: 0a:00.0
IF: enp10s0 state: up speed: 100 Mbps duplex: full
mac: 04:7d:7b:00:34:bb
Device-3: Qualcomm Atheros AR3011 Bluetooth type: USB
driver: btusb bus ID: 1-1.6:8
IF-ID-1: tun0 state: unknown speed: 10 Mbps
duplex: full mac: N/A
Local Storage: total: 596.17 GiB used: 13.97 GiB (2.3%)
ID-1: /dev/sda vendor: Toshiba model: MK6475GSX
size: 596.17 GiB
ID-1: / size: 577.15 GiB used: 13.97 GiB (2.4%)
fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap
dev: /dev/sda2
Processes: 180 Uptime: 8m Memory: 5.80 GiB
used: 1.07 GiB (18.5%) Init: systemd runlevel: 5
Compilers: gcc: 8.2.0 Shell: bash v: 5.0.2 inxi: 3.0.32

Thank you for looking into this.

This wireless adapter should work out of the box without any issue with the ath9k driver.

I found the solution to this pesky problem.
The puzzler was solved in a blink of an eye after enabling the Wireless radio button in System Settings --> Power Management. Available Wi-Fi conections are now showing in the Networks drop-down menu.

Ah. Good to know you found a solution.