[SOLVED] Wifi doesn't connect at startup

I have tried Netrunner 18.03 for a couple of days, and I really like it. However, everytime I start my computer, the wifi icon indicates that it is trying to connect to my network. I have to wait a few seconds for a a notification that says it failed to connect, and another notification that says no secrets were exchanged. Then I choose my wifi network, click connect and it instantly works.

It is not a huge deal, but kind of annoying.

Does anyone have a suggestion for how to fix it?

(My system language is Norwegian, so my translation may be slightly inaccurate.)

I have a laptop with intel i7-6700hq and integrated wifi.

That sounds a bit strange. Do you have checked if this wifi connection is marked as a ‘system connection’?
Have you tried already removing the saved configuration for this wifi network and readd it?

Thanks for your reply! I have tried removing the connection and setting it up again, but I haven’t checked if it’s a “system connection”. I’ll try that when I get home this afternoon.

I have had the same/similar problem.
My solution was to change password storage under the connections Wi-Fi Security tab to
Store password for all users (not encrypted)

It might be related to the starting order of kwallet and network init.

Btw, I’m on NRR

Ah ok. Good to know. Though still strange though as I can’t reproduce the issue. Smells like a race condition maybe.

This worked! Thank you!