back to Netrunner | back to Blue Systems

[Solved] wine32-development not installable on 17.10

Hello,

wine32-development is not installable on Netrunner 17.10.

[code]sudo apt-get install wine32-development:i386 libwine-development:i386 libfontconfig1:i386
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ant : Depends: default-jre-headless but it is not going to be installed or
java5-runtime-headless or
java6-runtime-headless or
java7-runtime-headless
ca-certificates-java : Depends: openjdk-7-jre-headless but it is not installable or
java7-runtime-headless
firefox-esr : Depends: libcairo-gobject2 (>= 1.10.0) but it is not going to be installed
Depends: libcairo2 (>= 1.10.0) but it is not going to be installed
Depends: libfontconfig1 (>= 2.12) but it is not going to be installed
Depends: libgtk-3-0 (>= 3.0.0) but it is not going to be installed
Depends: libgtk2.0-0 (>= 2.10) but it is not going to be installed
Depends: libpango-1.0-0 (>= 1.14.0) but it is not going to be installed
Depends: fontconfig
libtheora0 : Depends: libcairo2 (>= 1.2.4) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.[/code]

The problem is in package libfontconfig1:i386.

Cheers…

OK, found out that when I force the package libfontconfig1 to version 2.12.3-0.2 and also force the libfontconfig1:i386 to the same version, then it can be installed.