back to Netrunner | back to Blue Systems

(SOLVED) Wireless Printing


#1

I’m using Netrunner Rolling and I can print when my HP OfficeJet is plugged in via USB. However, my print jobs are “paused” when I try to print wirelessly.
From the HP Device Manager I ran the “Diagnose HPLIP Driver”. That gave me the following errors:


#3

What model is your HP?
Are you sure you have the URL correct?
Are you sure there is no firewall blocking it’s port?
What driver path (network protocol) are you using, LDP/LPR, DNS/SD, HTTPS, IPP, IPPS, Appsocket (aka jetdirect), SMB, etc.?


#5

I have an HP OfficeJet 6500.
Unfortunately, I’m not sure where to find the information to answer your other questions.
:confused:


#6

If you don’t know the url of the printer, or what network protocols are in use, how do you expect to print to it?
Moreover, how do you expect anyone to be able to diagnose the issue for you?
https://developers.hp.com/hp-linux-imaging-and-printing/models/officejet/officejet_6500_e709n


#7

I figured it out using the instructions below. However I had to do it twice. The first time, I was able to do the test print but nothing else. So I deleted the printer from my “Print Settings” and tried again. After the second attempt, everything worked. :roll_eyes: I’m not sure why it worked…because the “Diagnose HPLIP Driver” tool is still giving me the same error messages as I originally posted???

Oh well, hopefully it will keep working

[ https://unix.stackexchange.com/questions/359531/installing-hp-printer-driver-for-arch-linux ]

  1. Install CUPS: sudo pacman -Sy cups
  2. Start and enable (make it start after boot) the CUPS printing service: sudo systemctl start org.cups.cupsd && sudo systemctl enable org.cups.cups
  3. Install HP Linux Imaging and Printing: sudo pacman -S hplip
  4. Install a driver plug-in via sudo hp-setup -i . Root privileges are important here, otherwise it says “error: No device selected/specified or that supports this functionality.” when selecting a connection method. During installation of the plug-in, I selected the default option each time.
  5. Install system-config-printer , a GUI tool to configure printers.
  6. Start system-config-printer and click the button to add a printer. Select your printer and choose HPLIP as the connection method (see screenshot).
  7. system-config-printer should now allow you to print a test page.