[SOLVED]Wirless Drivers BCM43228


So I’ve just installed the Rolling version of net runnner but I can’t get my wireless working.

lspci gives me:
03:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n
ifconfig only finds my ethernet and lo
iwconfig doesn’t find anything either.

I assume it is a problem with drivers and have installed broadcom-wl and other broadcom packages I found on octopi, but still no sign of wirless anywhere (wifi-radar doesn’t detect it either).
An other problem I considered is that it’s maybe turned off, but I can’t find a way to enable it.

I am a beginer with linux, can someone help me?



I did a search on the net and that chip is problematic at best from not working at all to intermittently dropping the signal.

Remove all but the driver for your kernel.

The default kernel on 2014.09 is linux314, so unless you changed it this is the driver package that you need installed:

Next I will need to know what laptop model you have so I can help you with how to toggle the WIFI on/off?

The laptop is a lenovo thinkpad e530, il try the drivers in a bit.


Here is the user guide:

That model only has a software switch this is what you need:

Ok, so I tried to uninstall the drivers and reinstall linux314-broadcom-wl but everything is still the same.

but I found this out, both drivers I have for the chip were disactivated. I managed to activate bcma but can’t activate wl, I get: modprobe: ERROR: could not insert ‘wl’: Invalid argument

Any ideas?

mhwd -lh -d --pci

5: PCI 300.0: 0280 Network controller
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: network
Model: “Broadcom BCM43228 802.11a/b/g/n”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x4359 “BCM43228 802.11a/b/g/n”
SubVendor: pci 0x14e4 “Broadcom”
SubDevice: pci 0x0607
Driver: “bcma-pci-bridge”
Driver Modules: “bcma”
Memory Range: 0xe4100000-0xe4103fff (rw,non-prefetchable)
IRQ: 17 (no events)
Module Alias: “pci:v000014E4d00004359sv000014E4sd00000607bc02sc80i00”
Driver Info #0:
Driver Status: bcma is active
Driver Activation Cmd: “modprobe bcma”
Driver Info #1:
Driver Status: wl is not active
Driver Activation Cmd: “modprobe wl”
Attached to: #16 (PCI bridge)

Also the hardware detector says it’s installed:

Once you installed that package you need to reboot, the drivers will load automatically.

Second the laptop uses a software switch to turn on and off the Wifi Adapter.

This is normal:

I just tried formatting the partition and reinstalling netrunner then I installed linux314-broadcom-wl and turned of the power saving feature with # echo “options rtl8192ce fwlps=0” >> /etc/modprobe.d/modprobe.conf and reboot.

But my card is still not showing up as wlan0 (or anything else).

I think the problem might be here: lspci -k

03:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n
Subsystem: Broadcom Corporation Device 0607
Kernel modules: bcma, wl
0c:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
Subsystem: Lenovo Device 5000
Kernel driver in use: r8169
Kernel modules: r8169

It has the drivers but is not using them, is there a way I can fix this ?

Your chip-set requires the broadcom-wl version of driver and the one curently available/installed is, you have a two options here, wait for Manjaro to update this driver themselves or compile it from the AUR.

yaourt -S broadcom-wl


yaourt -S broadcom-wl-dkms

The broadcom-wl drivers are not available in the arch repositories and are Maintained by the Manjaro team for their distribution, I posted about this issue to the Manjaro forums so that they know to update the drivers…

Thank you for your help!
The wirleless now works without having changed the drivers. I updated the whole system which for some reason stopped it from booting correctly, I formatted the disk, started again and this time after: installing linux314-broadcom-wl, stopping the power saving option and an other system update, it finally worked after a reboot.