back to Netrunner | back to Blue Systems

Start job for TLP hang up


#21

I believe this latest one is the first one to have support, do you have any idea when netrunner will update to the newest kernel in their ISO?

Thanks for the article I’ll take a look at it.


#22

That ISO was shipped with the latest LTS kernel (4.19.x), just an earlier minor revision of it.
There have been some improvements to that kernel since it’s release.
A more current revision might fix your issue.

Like Manjaro we ship with the latest LTS kernel, not the latest greatest release kernel.
This is done so our end users don’t end up with an unsupported kernel installed.
When the non-LTS kernels hit EOL (end of life), they are orphaned, and Manjaro removes them from their repositories.

NOTE: I’m not ruling out systemd as a cause to your issues either. Manjaro was having some problems in that area back then as well.


#23

Ok, I’ll just wait for you to research the systemd issue? There isn’t anyway to install the latest kernel instead during boot is there ? To try it out ?


#24

There isn’t anyway to install the latest kernel instead during boot is there ? To try it out ?

No not really.


#25

After that , how can I put a " netrunner " spin on it ? Do I just add your repository while installing?

… I could have sworn I read something about Manjaro architect in this post somewhere … That’s what that statement is referring to.


#26

Yea, manjaro-architect would be too complicated a process, so I removed my comment.
It’s late here, so I will pick up looking into the issue some more in the morning, after coffee that is.

Have you tried running startx or startkde from another tty?


#27

No I haven’t . I’m not really sure about the commands for that.


#28

Those are the commands.

First see if there is a bios update available from Lenovo.
If there is, apply it using the bootable ISO.
https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-edge-laptops/thinkpad-e595-type-20nf/downloads/driver-list/component?name=BIOS%2FUEFI

If the bios (uefi) isn’t updated yet, or if your still having this issue after, try adding iommu=soft, and/or amd_iommu=pt ivrs_ioapic[32]=00:14.0 in kernel parameters of grub.
https://wiki.archlinux.org/index.php/Kernel_parameters#GRUB


#29

These kernel parameters didn’t seem to work either. I also got Condres to boot as well. I forgot what command I ran but it kept telling me the display wasn’t recognized. I guess I’ll have to wait for a new snapshot to come out. Any idea when that will happen ? Or If anyone in the community could just make an iso I could use with the latest kernel?