back to Netrunner | back to Blue Systems

Start job for TLP hang up


#1

I was excited to try the Rollin release on my new thinkpad E595 since I’ve had such a good experience with the Debian edition. However, I can’t even boot the live USB. The line that it’s stuck on is " waiting for TLP to start/stop job . Any ideas how to make it run or skip the tlp step until after install when I can tweak it more ?


#2

You might need to use some kernel parameters.
Have a look here:
https://wiki.archlinux.org/index.php/Laptop/Lenovo#E_series

If that doesn’t help, look through some of these for an answer.
https://forum.manjaro.org/search?q=Stop%20job%20for%20tlp

Other than that:
1: Compare your ISO to the checksum
2: Make sure you burned your ISO using the correct raw write style tools, like dd or suse studio, and not unetbootin or anything similar.


#3

I haven’t find a solution in either of those. I did burn the iso with dd as well.


#4

I did however go into try 2 and get the listing of inxi -Fxxx ( which was needed on a different forum ) and this is my output . I don’t know if this helps at all.


#5

If you can get into tty2 through tty6, then your system is not hung on tlp.
Systemd runs operations in parallel, what is on the screen may not necessarily be causing an issue.
It’s more likely that X, or SDDM isn’t loading properly.

No inxi doesn’t help here.

First lets see what is going on:

systemd-analyze blame

Then we need to look at the error messages in your log:

journalctl -p 3 -xb

#6

This is what I got . I also ran the command it suggested.


#7

This will more than likely not solve the issue, but when in console 2 run sudo systemctl stop tlp.service, just to see what happens.

Please the output of inxi -G


#8

It says that the command systenct1 or systenctl is not found. This is the output of the rest though .


#9

That was a typo, sorry about that.
Anyway, the command is sudo systemctl stop tlp.service

Your not loading any video drivers.
Your not selecting non-free when booting the ISO are you?


#10

I’ve tried with free and non free . Both stop at the same place , I just happened to not select it that time .


#11

The stop command just caused the timer to stop completly. I can still switch ttys and type commands but the start job isn’t running anymore .

This is the results of inxi -G with non-free drivers.


#12

Also the CPU is an AMD 7 3700U with integrated Vega 10 graphics. I did get Manjaro to install on it just fine though. So it must be something with netrunner specifically.


#13

Still no driver loaded.
You should be getting something like this:

[xxxx@xxxxx ~]$ inxi -G
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel  
          Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting tty: 240x67  
          Message: Advanced graphics data unavailable in console. Try -G --display
or:

[xxxx@xxxxx ~]$ inxi -G --display
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel  
          Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting tty: N/A  
          OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.1.5


#14

Which I don’t get because Manjaro ( which it’s based on ) just loaded with no issues.


#15

We use the exact same method and settings as Manjaro when it comes to drivers, etc. on our ISO’s.
Which ISO did you use (KDE, XFCE)?
Did you use an ISO from Manjaro with the same kernel, etc. (aka from around the same time)?
Now, the latest ISO’s from Manjaro would be newer, and so would the kernel, drivers, mhwd, etc…


#16

I downloaded the suggested ones from both . I also used KDE on both as well. I didn’t check kernel numbers but I just went with the " download here " links.


#17

I figured as much, to compare you would need to use an older ISO from Manjaro.
At any-rate, try re-downloading our ISO, or use a different USB stick?
I’ve had issues like this before just from a bad stick.


#18

I actually already have. I used a new USB stick as well as redownloading the iso. I’ve also tried writing it with suse studio and dd.

So netrunner is based on Manjaro , but not as up to date ? Will I just need to wait for a newer kernel with netrunner then ?


#19

Not exactly, our ISO is just not as new as Manjaro’s latest ISO.
It’s still a rolling release.

However, I’m not sure what kernel first supported your integrated gpu.
From your screenshots though, there is no kernel driver loading for it.


#20

Here is a review from back in June that had the same issue as your having, but using the Manjaro ISO at that time:

Quote:

The previous E585 had BIOS problems that made running Linux more difficult but not impossible. I have good news and bad news. The good news is that Lenovo fixed that problem in this model and most likely in the E/T485 as well. The bad news was that I encountered other minor obstacles. The first one was that on booting Manjaro 18.04 caused the laptop to be stuck on loading ‘TLP system startup/shutdown’. I’m not sure if this also effects other Linux distros but the problem was fixed in newer kernels so I downloaded the release candidate for 18.1 and it booted successfully.

P.S. I’m still looking into what could be causing your issue and a hopefully a solution to it.