steam error


I getting this error

“OpenGL GLX context is not using direct rendering, which may cause performance problems.”

Ironically, when I google’d this with Netrunner, it showed me a post I made earlier with the same question but with rolling instead. When I looked at Ubuntu forums with the same problem, but now with a different fork(this one) it gave me five commands. here is the link with those commands.

should I try and run those from the 14.10?

Or should I try something else?

in case it might be relevant, I have an a880gz mobo, amd 6670 gpu and AMD phenom II x4 965.



P.S. Wonderful OS.

First try reinstalling the amd driver. An update might have broke it. (It’s using its own opengl stuff and an Mesa update might have overwritten it)

I looked for an hour trying to conceptualize what I needed to do here. I am a bit emberassed to say I am unsure how to do this. this is a fresh install, but I would like to try and see if this fixes the problem. could you either point me to a link or show me a how to?



If it is a fresh install then you might not even have the proprietary driver installed.
All you need to do is go into the driver manager and it should take care of showing the correct driver for your card so you can install with ease

Even the opensource radeon driver shouldn’t be giving you this error either, this is more than likely a runtime issue with steam and the base systems libraries, you have to remember that steam itself is developed on the DeBian stable and that Netrunner 15 is based on an Ubuntu non LTS release. Personally, I would first follow the advice given in the first two posts from that askubuntu thread before messing around with the drivers.

Ok, I tried all three drivers and the error persisted.

I then ran this command

tar cjvf ~/.steam/gcc_libs_backup.tar.bz2 $(find ~/.steam | grep -e libstdc++ -e libgcc_s) && rm $(find ~/.steam | grep -e libstdc++ -e libgcc_s)

and now the open source driver works. dota 2 looks great! but is really, really choppy. I have read that proprietary might give better game performance, so I went to see if that might work better. I now get the same error as before. I switched back and forth and it was always the same. open work and proprietary get the same error.

I saw that this might be a potential fix.

Can you guys give a view of this post. I am feeling stuck again and need another pair of eyes. I need to check and see if the user is in the video group which I’m unsure how to do.

the second part of that link which I haven’t tried was the installing of mesa-libs:i386

I tried this command
sudo apt-get install mesa-libs:i386
but in came back with
E: Unable to locate package mesa-libs

any ideas?



Steam is a 32 bit application and will not use any of the 64 bit libraries. You will need to install 32-bit libraries on a 64 bit system to use steam (multiarch). The mesa-libs package doesn’t exist on Ubuntu based systems you must have read Debian instructions
Try this:

sudo apt-get install mesa-utils:i386 mesa-utils-extra:i386


What I decided to do was to reinstall, go ahead and use the open source drivers and I run this command.

tar cjvf ~/.steam/gcc_libs_backup.tar.bz2 $(find ~/.steam | grep -e libstdc++ -e libgcc_s) && rm $(find ~/.steam | grep -e libstdc++ -e libgcc_s)

I then turn off all the fancy stuff like vsync, etc. Dota 2 looks better on windows partition, but I actually find it easier to process information now. The resolution is still the same, the effects are just turned down.

Thank you all for the help!