back to Netrunner | back to Blue Systems

Synaptic not opening up[solved]


#1

Hello
Moved over from Netrunner Rolling to Netrunner Indigo yesterday
offtopic - I think my DVD diskdrive is breaking down took many hours to install,

After updating Indigo and adding firewall went to open Synaptic prompted for password ok and nothing happened synaptic didn’t open even after a few attempts
Tried to open synaptic in terminal after a bit of chasing around found that an error : libxapian.so.30: file not found , cannot open, could be the problem,
Did the terminal, purge synaptic, reinstall it , upgraded, still after every effort more than one time, synaptic didn’t open, did I forget to do anything?

next plan was install some software in terminal that worked got installed gimp resythersizer (found it in plugins folder so I knew it would be good to go)
and also got gimp Gmic filters for special effects,couldn’t find it.
the two lots of filters did not load into gimp after restart gimp then reboot desktop still not find the two filters anywhere took my time to look in all menus and rebooted again made no improvement,

Are these two events are connected synaptic and gimp plugins downloads not showing,
what have not done or seen here?
If I could get libxapian.so.30: on board would that maybe fix synaptic,
Discover could not find libxapian.so.30:, same in terminal no such file,
Out of ideas.
Any help will be appreciated just to get synaptic working that be real good.
Thanks in advance


#2

There is a package called libxapian30 that you need to have installed and synaptic is depending on it.
So I think maybe it is broken.
Try reinstalling it with the command:
sudo apt install --reinstall libxapian30

I hope that works for you.

As for Gimp and GMic.
I just installed the package gimp-gmic and could find the Plugins then in Gimp -> Filters -> G’MIC Qt

Hope that helps :slight_smile:


#3

Thanks leszek

from all the commands I was using that’s the only one I didn’t use now synaptic ( muon now opens also tried last night but no good last night), in a few days I’ll have more time to look into Gmic etc, did reinstall it now, that did nothing, it will just have to wait I have time to do something and also think up of what to do.
Thanks Lezsek.


#4

Reinstalled Netrunner Indigo from a usb instead of the slow troublesome DVDdrive

this

there must be something wrong with my install yea it was the DVDdrive
and now everything seems to work the way it was to be inc gimp-gmic,

Thanks Leszek

:clap: