System sluggish and noisy CPU after today's [2014-10-11] upgrade


So, I did today’s major upgrade (Dell Latitude E5510, Kernel: 3.16.4-1-MANJARO x86_64, Intel HD Graphics Card).

After pacman -Syu finished normally, I ran

mhwd-gpu --setgl mesa

per suggestion of Pacman. Reboot went fine, and I logged into KDE desktop, so no X11 issues. However, my system is now extremely sluggish: Desktop cube is slow, text and scrolling in Firefox and Chromium lags noticeably behind mouse/keyboard, and my CPU is very noisy and core temperatures are in the 70-80 C range (before the update they were typically around 40-50 C)

I don’t know what went wrong. I tried booting into the 3.10 kernel, the situation is the same.

Any suggestions?
I forgot to mention, my original installation was Rolling 2014.04, so perhaps this post should go there.

You could try check the CPU Usage if it is related to any application.
Also check the desktop effects and try playing around with the Composite Type. Usually OpenGL 2.0 should work fine. If it isn’t try all the alternatives which works best for you.

Most CPU-intense tasks are: Chromium, kwin, Xorg and plasma-desktop

I already use OpenGL 2.0 with Raster. OpenGL 3.0 crashes the desktop.

This was definitely caused by the upgrade. It’s a very strange problem, since only some things have slowed down (graphics and text in the browser). applications start quickly, usually, terminal and kwrite/kate typing is responsive.

I noticed that after the upgrade I have Plymouth boot splash (I think that’s Plymouth, I get a spinning Netrunner logo), which I didn’t have before – frankly, I prefer just systemd text. How can I disable it, and should I do that?

You can disable plymouth by removing the splash boot option in /etc/default/grub. You need root rights for that and there is a graphical configuration tool in systemsettings startup and shutdown.
When it comes to the problem itself it seems to be a driver issue. Iam not sure how to fix that though.

Same here.
On Rolling 2014.09.
Installed the new package, then had to revert kdmrc changes to log in normally.
Google chrome is especially bad… but virtually everything is (minimizing animations, scrolling animations etc…)
Maybe the new version of X server that’s causing it?
Also had to install Mesa-DRI drivers.

im a newbie. been working on netrunner for the last month

danr4, do you have any older kernels installed? If so, can you check if the problem appears when you boot in a different kernel? For my part, I have 3.10 installed, and the problem appears there too.

If it appears on older kernels aswell, then it is definitely a Xorg or Mesa problem

So, is there nothing we can do? Any way to find out which driver is to blame and revert to an older version?

I would really hate to have to re-install the system, since I had configured it to an almost perfect state :frowning:

I was running on 3.14 kernel when i upgraded. after I fixed the boot problems and saw the performance issues I installed 3.16 hoping it’s some compatabillity problem, but it’s the same.
My guess is X server configuration leftovers or overwrites that are incompatible with the mesa-dri-intel-whatever but i’m not experienced enough to quickly understand what is the root cause.

BTW i’m running a 2010 machine with ATI mobility 5650 switchable graphics which I couldn’t get to work, so i basically only use the integrated intel gpu.

I read somewhere on manjaro forums that X isn’t suppose to use /etc/X11/xorg.conf, but removing it renders it unable to boot. what’s that about?

I’m thinking of using downgrade,

although I’m not sure what to downgrade: possible options are the xf86-video-intel, xorg-server or mesa (but I only have one version of mesa-dri). And I’m not sure it’s a good idea, since I have very little experience with downgrades. And we’re talking about the very guts of my system, here :-/

Sorry I can’t help here as I also don’t have experience with downgrading on manjaro.
The only thing I know is that I would recommend downgrading xorg and the intel driver first.

Ok, I’ll take a look at manjaro and arch wiki. Is there perhaps any particular order in which I should do the downgrades?
Ok, apparently I had underestimated the depth of this rabbit-hole…

So, I cannot downgrade xf86-video-intel, because that would require installing glamor-egl. But glamor-egl has been rendered obsolete, since it is in conflict with the new xorg-server. And I cannot downgrade xorg-server, because I would then have to remove xf86-input-[a bunch of cr*p] – i.e., half of X11. :frowning:

In other words, I’m stuck with a busted system, until some upgrade fixes it, which probably won’t happen soon because the bug isn’t all that common, I gather.

These are known issues with the 3.16 kernel, I would recommend moving back to the 3.14 LTS series kernel using the MHWD gui tool in the Manjaro Settings Manager.

Menu > Settings > Manjaro Settings Manager > Kernel


Thank you, I will try it out. Although, as I wrote, the problems seem to be independent of the kernel used, and were present in 3.10 LTS, which is also installed.

It’s the same with the 3.14 LTS.

Seems like the boot problems are recurring…
Sometimes I get “Waiting for X server to begin accepting connections”, sometimes i don’t…

Another symptom:
constantly scrolling up & down on sublime text creates choppy animations and Xorg.bin CPU usage sky rockets to around 25%

I’ll try downgrading to xorg 1.15 too

No, unfortunately 3.14 LTS makes no difference. Unless I’m missing something here, I see the exact same lags and performance issues.

Hmm, All my machines are Intel graphics based and I haven’t seen any issues so far.
May I suggest searching the Manjaro forums for anyone with the same issue.

danr4, I wouldn’t advise it… As I said, I tried to do that, and I found out there are a lot of interconnected packages, so that a downgrade would almost certainly leave me with a crippled system.

I’m considering a re-install, but I’m very reluctant, as I haven’t got the time for that, and also I’ve configured the system extensively since I installed it 2 months ago.[/quote]

I’ve searched both Manjaro and Arch forums a bit. I haven’t found exactly the same issues, but the problem of slow chromium connected to intel graphics crops up a lot.
For the time being, I’ve worked around it by disabling hardware acceleration in chromium, of course that’s not a solution, but at least I can post while I’m young :stuck_out_tongue:

I haven’t found anything resembling the rest of the issues (CPU usage/desktop effect slowness). After installation, I had issues with tearing, which I resolved using

Option "TearFree" "true"
Option "AccelMethod" "sna"

in /etc/X11/xorg.conf.d/90-mhwd.conf

I suppose the intel/xorg update negated that fix, but I don’t know how I can restore it without rolling back to that configuration, which is very difficult.

yep, i quickly realized trying to downgrade will cost more time then doing workarounds…
also disabled hardware acceleration… but developing on Sublime Text became really annoying

the laggish scrolling in Sublime are more apparent when im in full screen mode.
Maybe its RandR related?

BTW, Avonidas, is there anything weird in your /var/log/Xorg.0.log ?
if you do $ cat /var/log/Xorg.0.log | grep EE

I have this:
(EE) systemd-logind: failed to get session: PID 406 does not belong to any known session

It might be something related to the rootless access:


(EE) systemd-logind: failed to get session: PID 1121 does not belong to any known session

Also, I did try a downgrade of xorg and intel driver, doing all the dependencies manually. It booted fine, however the problem remained, so I re-run pacman -Syyu, and now I’m right where I started :@ Perhaps I should try downgrading mesa, or some other packages… the possibilities are endless :s