Netrunner Home

System Start-up Time [Solved]


#1

I followed the tutorial to get packages from the Backport channels right after installing Netrunner 19.01.

Towards to the end of installing the packages the installation process stopped and dialog window indicated the following text:

[…quote]
Replacing config file /etc/default/grub with new version
The grub-pc package is being upgraded. This menu allows you to select which
devices you’d like grub-install to be automatically run for, if any.

Running grub-install automatically is recommended in most situations, to prevent
the installed GRUB core image from getting out of sync with GRUB modules or
grub.cfg.

If you’re unsure which drive is designated as boot drive by your BIOS, it is
often a good idea to install GRUB to all of them.

Note: it is possible to install GRUB to partition boot records as well, and some
appropriate partitions are offered here. However, this forces GRUB to use the
blocklist mechanism, which makes it less reliable, and therefore is not
recommended.

  1. /dev/sda (500107 MB; WDC_WD5000AZLX-22JKKA0) 2. - /dev/sda1 (490655 MB; /)

(Enter the items you want to select, separated by spaces.)

GRUB install devices:
[unquote]

I thought that after a short period of time the installation process would continue automatically, alas it didn’t.
So I typed /dev/sda (following item GRUB install devices:) and hit the Enter button on my keyboard.

Synaptic then finished installing the packages.

The rebooting process took a little while to complete and subsequent reboot times seem longer than usual.

After Shutting down the system, the Start-up time is even longer (2 - 3 mins).

Be that as it may, once fired up Netrunner is running flawlessly!

I wonder if I selected & entered the wrong item and is affecting the Start-up or reboot time; If so, is it possible to rectify this situation?


#2

No you did everything correctly.
The delay must be caused by something else.
You can open a terminal and run the command

sudo systemd-analyze blame to see which service is causing the delay.


#3

Thank you, good to know I installed GRUB correctly.

First run right after first System Start-up of the day:

karl@desktop:~$ sudo systemd-analyze blame
[sudo] password for karl:
1min 43.546s apt-daily.service
24.823s man-db.service
9.824s logrotate.service
7.751s NetworkManager-wait-online.service
6.762s dev-sda1.device
5.652s ModemManager.service
5.348s exim4.service
5.237s udisks2.service
5.196s smbd.service
3.820s accounts-daemon.service
3.549s nmbd.service
2.963s alsa-restore.service
2.931s avahi-daemon.service
2.920s systemd-logind.service
2.385s NetworkManager.service
2.384s wpa_supplicant.service
1.842s upower.service
1.662s systemd-udevd.service
1.294s apparmor.service
835ms ssh.service
801ms virtualbox.service
766ms systemd-modules-load.service

I then downloaded/installed from Synaptic memtest86+. The run passed 2 times with 0 errors.

Second run right after System Reboot:

karl@desktop:~$ sudo systemd-analyze blame
[sudo] password for karl:
5.590s NetworkManager-wait-online.service
5.521s ModemManager.service
5.102s udisks2.service
4.503s accounts-daemon.service
4.420s exim4.service
4.360s dev-sda1.device
2.843s nmbd.service
2.540s rsyslog.service
2.538s systemd-logind.service
2.538s lm-sensors.service
2.533s alsa-restore.service
2.492s wpa_supplicant.service
2.491s NetworkManager.service
2.489s avahi-daemon.service
1.984s smbd.service
1.892s upower.service
1.651s systemd-udevd.service
1.263s apparmor.service
1.010s polkit.service
930ms systemd-tmpfiles-setup.service
805ms sddm.service
775ms ssh.service

I then downloaded/installed from Synaptic stress and stress-ng. The test results seem normal.

Third run after System Shut-down/Start-up:

karl@desktop:~$ sudo systemd-analyze blame
[sudo] password for karl:
12.896s NetworkManager-wait-online.service
11.925s smbd.service
7.182s exim4.service
4.739s ModemManager.service
4.475s dev-sda1.device
4.163s udisks2.service
3.846s accounts-daemon.service
3.340s nmbd.service
2.511s avahi-daemon.service
2.440s upower.service
2.142s NetworkManager.service
2.055s alsa-restore.service
2.054s wpa_supplicant.service
2.053s lm-sensors.service
2.048s systemd-logind.service
1.638s systemd-udevd.service
1.635s virtualbox.service
1.392s apparmor.service
788ms systemd-modules-load.service
772ms ssh.service
750ms systemd-tmpfiles-setup.service
602ms sddm.service

Note: The first three items in the first-run list are not shown in subsequent checks and don’t know the significance of these omissions but understand that these services may play a part slowing down the system start-up process (?) .
Also, my reason for applying memtest and stress was sudden ‘freezing’ of the operating system.

Be that as it may, since running the tests the system start-up time has definitely and magically improved and hope the freezing was a temporary glitch too.

At this particular point, the system start-up time is not a issue anymore and mark this topic as [Solved].

Thanks again for your kind assistance and pointing me to ‘systemd-analyze blame’.


#4

If you encounter the issue again and apt-daily.service is to blame you can also deactivate this service.
This service auto connects in the background and refreshes the software list and checks for updates at bootup.
This can take a while depending on the server speeds and sources lists you have activated.