System Update Problems

Hi Guys, I had a notification update this morning and since then a red cross has appeared in the bottom bar and if I go to system settings I get this messageystem “Settings was unable to find any views, and hence has nothing to display”.

Did you upgrade your system ?
Was there any problem on upgrade ?

Same here. I ran a fairly large bunch of updates earlier, and then when I went to look for the Muon package manager later it was not there, nor were a lot of other things. I logged out and in, which did no good, then noticed the red X where the sound volume control should be. I just tried System Settings, which still has an icon, but got the same message as above.
It’s too late at night here to do anything further, but a hint as to how to rectify matters would be appreciated.
I still have Synaptic. It shows all Muon packages as not installed. Aside from installing stuff as I find it missing, what can I do?

Somehow the upgrade must have delete it aswell as other applications. Didn’t the update show a list or warning that packages are getting removed when you click update?

Same problem here, now, after running latest updates. Packages were marked for removal during the process but that’s been the case sometimes before and it doesn’t usually break anything.

There was a list, but I assumed that it was the usual “these things too …” list so I OK’d it. Siily me. Other things on my mind.

Same here, basically. I’m just too trusting that the system knows what it’s doing, I think. I should have learned my lesson by now as I’ve never run an OS where an update didn’t break something at one time or another, whether it be Windows, MacOS, or some version or other of Linux.

If you see the other thread a normal muon update shouldn’t break anything as it only marks packages to update that don’t remove other packages. If you of course mark those packages aswell and hit ok on the notification that packages are going to be removed then it is another problem.

I’m now wondering if there’s some way to find out exactly which packages were removed. Does the system save a log of some kind?

Yeah in /var/log/dpkg.log

I didn’t purposely mark any packages that weren’t already marked. I suppose there is a remote possibility that I clicked on something by accident… but it seems unlikely.

Thanks. I’ll see if I can fix this mess using Synaptic. If not I don’t mind reinstalling the whole system, I already have almost all my files backed up and it doesn’t really take that long.

PS: On a fresh install when doing apt-get dist-upgrade it tries to remove these packages

So make sure that these are installed.
Also make sure the kubuntu backports ppa is activated.

I guess the netrunner-apt-config package needs to be updated first as it contains the “activated” kubuntu backports ppa and if it isn’t activated this might cause the current update problems.

Great. Looks like the "remove"s are all there. I’ll fix it up in the morning. Thanks.

Anyone wanting to upgrade from 14.0 to 14.1 should do the following in a terminal
Updated instructions

sudo apt-get update && sudo apt-get upgrade && sudo apt-get update && sudo apt-get dist-upgrade

Strange. According to Synaptic the netrunner-apt-config is up to date, but the kubunto backports ppa is not activated. :frowning:

Try to refresh synaptic and see again. Maybe the cache is not up to date.

Yeah that did it, but it’s odd because I had refreshed synaptic a few minutes ago!

Yeah there was another problem with netrunner-apt-config being in the frontier-updates ppa but was not seen as upgrade candidate due to apt-pinning. I copied it over to the frontier-14-packages ppa were it should be available now as update candidate

Update: The initial error should now be fixed by disabling the direct initial update to KDE SC 4.14.2.
A full dist-upgrade to KDE 4.14.2 should be possible after a normal “apt-get upgrade” followed by another “apt-get update”.