Task Bar Disappears

New install of Netrunner Rolling; I have three virtual desktops. From time to time, two of the three will lose the task bar, desktop icons, and background image. Open programs continue to run, but if minimized, disappear. I can ctrl-f1,2,3 to scroll through the desktops, still.

Neither logging out or starting a new session will clear this up. It will usually just sit there until I turn the laptop off and back on.

Any thoughts?

Ron

Can you press Alt+F2 to start krunner and execute ksysguard to see if the process plasmashell is still running?
If it isn’t this means your desktop crashed and you can restart it by executing plasmashell.
If it is still running it might be a graphical glitch in your driver + hardware combination.
For this I would suggest go into systemsettings -> monitor settings and tweak around the compositor settings. Like choosing a lower OpenGL Backend or try to use EGL as backend.
If it happens the next time you can try pressing Alt+Shift+F12 to disable the desktop effects temporarily

Do you have Intel graphics?
If so, I suggest setting the compositor to opengl 2.0 or lower, use smooth for the scaling method and automatic for tear prevention. These settings seem to be the most stable.

It took two reboots to clear up the trash left by the last event (wireless wouldn’t stay connected). I have tried, as you both suggested (AJSlye & leszek), to tweak the compositor settings (I do have Intel graphics). Hopefully, this will correct the problem. I’ll post any results as they occur. Thanks to you both!

Ron

Oct. 26, no problems as of yet. Changed Rendering Backend to OpenGL 3.1, from 2.0
Oct. 28, still truckin’ (Nice highjack of the thread…)

Yep I have had this issue also using default open drivers with a legacy Ati 4350 running dual displays.

Mouse wheel rolls my Virtual desktops set to 4 and 4 which gives me Up Down rolling of Virtual spaces. And seems launching and using different programs and rolling to different desktops. Gives me the one monitor black and disappearing panels sometimes. Can Ctrl-Alt-Backspace to log out to Logon screen. And re-log in. And sometimes that even doesn’t work and requires me to Reboot.

Sometimes the right screen loses wallpaper and right-click desktop capability. Also Opening splash of apps will open on right screen tho application opens on left. Have Left VGA-0 set as primary and DVI-0 is my right monitor.
But for some reason Plasma keeps thinking that my right monitor is primary?
Seems some confusion on Plasma’s part.

Really need a easy way to reset and re-run Plasma and re-set the desktop.
Beyond cryptic commands in the shell or krunner.

Or guess just wait until these major bugs are squashed I guess.

Yes, like I said, this seems to be a compositor issue, if you play with it’s settings, you can achieve different levels of stability. Only disabling the compositor completely would achieve complete stability on my system.

However, with the last update-pack, KDE frameworks 5.15 seems to have made the compositor a bit more stable, and it’s now remembering the monitor positions and settings when I plug in and out my hdmi cable, and at least on my system that is.

That’s good to hear. And have positive vibes that it will be resolved in upcoming updates. Unlike others that will go unnamed. Plasma 5 & Manjaro/a.k.a. Neturunner teams are top notch resolving these issues quickly.

Tho still missing a way in KDE to auto-mount external usb drives. As shy away from editing fstab.
And this solution no longer works. https://forum.manjaro.org/index.php?topic=24048.msg208785#msg208785

Think you mentioned Gnome-Disks? Isn’t that Un-Clean & Forbidden on a KDE Desktop? :s

Plasma 5.5 should reintroduce that feature to auto-mount again.
There was a graphical tool (and in Debian at least it is still maintained) called disk-manager. Not sure if this is packaged somewhere for Manjaro/Arch.
It is basically a graphical fstab editor.

Yep remember reading it coming back in 5.5 which is slated for Dec. 8th release.
So at least I can auto-mount to my hearts content for Christmas! :stuck_out_tongue:

And yep not really wanting to do the old school fstab way. Even tho it’s a viable solution.
And disk-manager doesn’t show in Octopi or the Aur.

Tho a search shows udiskie and udisk udisk2 installed. But that is for CD Drives,usb keys and such. Don’t know if it is viable to use to automount external usb drives on boot tho. https://pypi.python.org/pypi/udiskie

But did find turning off fade to desktop. Shows the theme panel issue of splash background before panels refresh and populate.


.

The last commit to disk-manager was back in may of 2011.
https://code.launchpad.net/~givre/disk-manager

I could build the last release (1.1.1) and add it into our repository, If anyone is interested that is?

If easy-peasy no problem if it will solve the issue. But don’t jump thru too many hoops or somersaults to get it there.
As you already do major hauling for Netrunner which is greatly appreciated.

UPDATE: Strange re-booted and open Dolphin and they weren’t mounted.
But then looked back 10 seconds later and they all where mounted. Strange Delay.

What Did you do AJSlye ? I Know it Was Something You Did! :stuck_out_tongue:
.

Well, udiskie-tray is a pygtk tray application.
How are you loading it on startup?

Did do nothing but use that thread solution of kded phase change back to zero and running those kde4 modules.

What is even stranger. Boot up don’t do anything but open dolphin. Sit and wait 1min. 2min. nothing happens. Click in folders. Click on menu open a terminal still not auto-mounted. But soon as I launch Firefox BAm! the drives mount in Dolphin.

The last time they mounted in 10 seconds. But that was because you guessed it I had launched Firefox.

More weirdness. Will see if it’s just Firefox or any apps. Time to Reboot again.

.

OK, that is weird, what would firefox have to do with anything?

Anyway, disk-manager want’s pygtk >=2.6 and we have 2.24.0, evidently the number is confusing to the ./configure script.

As far as using gnome-disk-utility, no not really an issue. Gnome disks is actually the palimpsest utility before it was adopted by gnome and doesn’t really have any actual Gnome dependencies:
Depends On: udisks2, gtk3, libsecret, libpwquality, libcanberra, libdvdread, libnotify, desktop-file-utils, parted

If you prefer the old Gnome/gtk2 version then there is mate-disk-utility:
Depends On: avahi, caja, dbus, gtk2, libatasmart, libsecret, libnotify, libunique, udisks

Well rebooted and wonkers bootup. As again had the one screen left with conky on it. Conky should be on the right monitor. The right monitor was black no wallpaper and no right-click ability. Rebooted again. And booted up normal desktop.

Opened Dolphin and let it set there while I read for 10 mins. Devices still didn’t auto-mount. Ran Terminal,Octopi,System Settings,Ksyslog,Vlc nada nothing. Soon as I ran K3b then boom all 4 mounted in dolphin.

Will verify with Firefox again next time I boot and try some other apps.

Tho at the moment I’m All Booted Out! :smiley:

OK, I think I know what’s going on, they are not mounting untill an application that was built for KDE 4 launches.
The firefox-kde patches are still based on KDE4 libs and configuration files.
The k3b frameworks port isn’t finished yet either, the releases from upstream are still using kdebase-runtime.

Ahhh makes sense. Welcome to Bizzaro Plasma 5! :stuck_out_tongue:

And no Biggie as I Always open Firefox & Dolphin as my first two apps on the desktop.

Well, Dolphin is now the frameworks version, dolphin4 (the dolphinpart4 package) is the older kdebase-runtime version.

Seems still in much a transitional state still.

Yep another annoying Plasma 5 themeing thing. Is I can Get New Decorations for Window Decorations thru the built-in downloader.
But none of them work right. using the dark org.kde.oxygen which works as intended.
But any others I try end up with missing resize arrows and can’t re-size apps.

Auroblack,Carbon,Dark-Translucent,PapirusDark,simplicity,zink. Some nice ones I would prefer.
But no Damn Re-size arrows for resizing applications.

One of my pet peeves with the built-in getter of themes and decorations,icons,etc… No damn standards or QA.
Some popup a html link to a separate site. Others install but then don’t show up in System Settings at all.
To half-baked and incomplete themes.

Seems to be a Turkey Crap Shoot on what you will get from there. :frowning:

.

Yes, Plasma has issues with some of the Aurorae based themes, not to mention some of the entries are just links to websites like deviant art, etc. I havent really used the built in utilities for these very often, and also had the same kinds of issues with them.

The Carbon themes are Netrunner built and are already in our repository.
aurorae-theme-carbon
carbon-gtk2
carbon-gtk3
carbon-qt4
carbon-qt5

As well as:

Aurorae Themes:
aurorae-theme-forman
aurorae-theme-gnome3
aurorae-theme-metrodark
aurorae-theme-win7

Desktop Themes:
desktop-theme-eclipse
desktop-theme-diamond
desktop-theme-enlightenment
desktop-theme-gnome-shell-kde
desktop-theme-orange-lightning
desktop-theme-sevenified

Wallpaper packs:
netrunner-rolling-wallpapers-2014-04
netrunner-rolling-wallpapers-2014.09
netrunner-rolling-wallpapers-2015.06

Fonts:
ttf-casper-typeface
ttf-ms-fonts
ttf-noto-sans-fonts

Icons:
netrunner-flattr-icons
netrunner-moka-icons

Cursors:
netrunner-whiteclassicia-cursors
netrunner-windows-cursors

And more to be added as time goes on.