Time incorrect

Although I have set correct time zone during install, time widget shows always one hour less. How do I fix this?

Also, in Day/Time settings, when I click to automatically set day/time check box it doesn’s stay checked. No such behaviour in Kubuntu 11.10 with KDE 4.8.2. Is it a new feature of KDE 4.10.1?

No it does work but I noticed some bugs when updating from KDE 4.8.2 and you may have to reset your hidden .kde file.

Well, I did a clean install of 12.12.1 which came with KDE 4.9 then upgraded to KDE 4.10.1.

In the meantime I tried changing time-zone with dpkg-reconfigure tzdata. It reported correctly that local time is one hour more than UTC but that doesn’t affect the widget which seems to be showing UTC.

What do you mean by “reset your hidden .kde file”? Surely, you don’t mean deleting /home/.kde? I’d hate to lose that fancy desktop. :s

This problem with time sucks!:@

I went through the pains of re-installing/upgrading the system again thinking that I have a corrupt system and the problem still persists. Makes me wonder if KDE devs ever check their code.
To add insult to pain, the second time around, everything Muon* is gone from the system.:@

I think I know now what caused all this mess.

The trouble was backports ppas are on. DryLand 3rd edition comes with KDE 4.9.4. If update is attempted after install, as I did, KDE is upgraded to 4.9.5 and because backports are on, upgrade to KDE 4.10.1 is also attempted and this seems to be causing mess. I have disabled backports, clock is working properly(although checkbox still woun’t stay checked) and Muon is in place.

To the devs of NetRunner, if you are reading this, with best intentions and I very much like your minted Kubuntu, please, make backports disabled by default.