TLP prevents connected USB devices from charging

Although I’m running Netrunner Rolling on my desktop, connected USB devices (phone, tablet) wouldn’t charge.
Only after disabling TLP in /etc/default/tlp connected USB devices are charging.
So maybe we have a configuration issue here?

That’s strange, my phone and tablet are both charging fine when connected to my systems with TLP enabled.
Besides. if it wasn’t providing power than my 1TB WD “My Passport Ultra” USB drive wouldn’t work at all.

May I ask what devices your having this issue with, and the type of USB ports you have?

My usb ports are 1.x and/or 2.x, I have no 3.x or type-c ports to check.
Phone is a iPhone 3GS running IOS 6
Tablet is a ASUS transformer running KatKiss Lollipop.

I just found this:
You may need to blacklist your smatphone from auto suspend.
Evidently not all smartphones suffer from this issue.

So, I’ve now tested with three phones:

  • Samsung GT-S 7562
  • Huawei U8666E
  • Honor Holly U19

In addition, I tested with two different USB cables.
In all cases, the results were the same: TLP enabled > no charging, TLP disabled > charging.
This is true for both USB 2 ports (front and rear) and USB 3 ports (rear).

Mobo: ASUSTeK model: M4A87TD/USB3 v: Rev 1.xx Bios: American Megatrends v: 2001 date: 03/08/2011

CPU: Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB
clock speeds: max: 3400 MHz 1: 2700 MHz 2: 800 MHz 3: 800 MHz 4: 2200 MHz

Did you follow the link I gave you?
For most smart phones you will need to blacklist the phones device ID.
This is because many smart phones have issues waking up from autosuspend.

Please read the following links:

Note: it would be impossible to blacklist every smart device on the market that has this issue by default. (mostly android phones).

I didn’t have the time to do so yet, but as soon as it’s done I’ll report back.

I’ve now tested blacklisting (sorry for the delay) and it does the job.
Once blacklisted, the phone will charge while TLP being enabled.

Is the correct mail application set in systemsettings > default applications ?
If yes and isn’tworking you have to manually set the correct mail client in firefox configuration mime types.

Servicing Stop complaints