Unable to install Crossover 14.1

I have to admit I’m a little surprised at this. I jumped ship from Ubuntu Gnome 15.04 yesterday, and getting crossover installed was not a problem there - so given the common lineage I’d have figured it would be similar.

So I’m trying to install Crossover 14.1, using info here: https://www.codeweavers.com/support/wiki/linux/faq/Ubuntu/VividVervet

It seems to get hung up on lib32nss-mdns as a dependency.

If I try to add that dependency manually via terminal I get this:

The following packages have unmet dependencies: lib32nss-mdns : Depends: libnss-mdns-i386 (= 0.10-6) E: Unable to correct problems, you have held broken packages.

However, sudo apt-get -f install doesn’t seem to do anything (nor did it throw an error), and synaptic shows no broken packages either. (I realize they are both checking against the same info, but when I have trouble I like comparing their output.)

If I try to install lib32nss-mdns via synaptic I get the image below, which is kinda surprising.


At a quick look, many of those are metapackages, but this still seems odd to me, and there are things like my printer driver in there that I do not want to lose.

Any ideas?

This is a relatively fresh install. I have added the kubuntu-backports PPA and upgraded from there. I have also installed a couple of things and tweaked the visuals a little bit, but that’s about it. None of what I’ve done seems likely to be causing this issue to me, but perhaps I’m wrong.

Note: If it becomes clear that the backports PPA is causing this somehow, I’m happy to do a fresh install over again, without adding that repo. ppa-purge gave me pages of complaints when I tested to see how hard it would be to get rid of, so it will be a reinstall…

Edit: So instead of using whatever KDE equivalent to gdebi is popping up to try installing the package, I just did it with dpkg. Of course it installs fine, so I thought I’d launch it just to see how much it would compain about that one missing dependency. It immediately tries to install it itself, and the output is at least a little more detailed, though I still don’t know what to do about it:

The following packages have unmet dependencies: libnss-mdns:i386 : Depends: base-files:i386 (>= 3.1.10)

Seems like you try to install i386 packages on an amd64 Plattform. Todo this you need to enable i386 support if it isn’t.
The easiest would be running

sudo dpkg --add-architecture i386

After that refresh the package repo list and you should be good to go.

I hope this fixes the issue for you.

I did that at the very beginning of the process, but I appreciate the help!

I hate to admit it, but I finally fled over Antergos last night to see if I’d have an easier time of it there, and I did, so that’s where I’m at now.

Was going to delete this thread if no one replied yet, but you beat me to it!

I any case, I appreciate your reply and help. Thanks!

Have you tried our Rolling edition based on Manjaro yet?
If not you could try out our pre3 ISO or wait for the final release.
I wouldn’t suggest using the current 2014.09 release iso though, there have been many many changes to the system since these were released almost a year ago.

I’m a huge fan of Netrunner-Rolling - ran with it for much of last year and the beginning of 2015 - but I hadn’t tried Antergos in a good long while, so now that I’m there I’ll probably stay for awhile.

But thank you for the suggestion, and all the helpful posts of yours that I’ve read in the past. :slight_smile: