[Update] 2015-04-06

Manjaro 0.8.12 update-pack 6 now online:

Included in this update-pack:
Plasma5 -> 5.2.2
Octopi -> 0.7.0rc1
Firefox and firefox-kde -> 37.01
Thunderbird and thunderbird-kde -> 31.6.0

Current supported kernels:
Linux310 3.10.73
Linux312 3.12.39
Linux314 3.14.37
Linux318 3.18.11
Linux319 3.19.3

This update-pack also includes all regular Archlinux upstream fixes as of April 6, 2015.

You can perform this update as usual using octopi or from the command line:

sudo pacman -Syyu

Note: A reboot is required if your running kernel received an update.

Official Manjaro announcement: https://manjaro.github.io/Update-2015-04-06_(stable)/

99 updates went well no issues. Even upgraded to using newer 3.19.3 kernel seems smooth and zero issues for me.


Since this update, firefox-kde doesn’t start anymore. I see this error message: GLib-CRITICAL **: g_slice_set_config: assertion ‘sys_page_size == 0’ failed.

Any hints anyone?

Thanks in Advance

Try make sure you moved the blueshell repository to the bottom of your pacman.conf file otherwise you may have some updating issues, this can be achieved as root with a text editor, or by installing and using the octopi-repoeditor:

 sudo pacman -S octopi-repoeditor

next make sure to update your mirrorlist and reorganize it fastest to slowest:

sudp pacman -S pacman-mirrorlist sudo pacman-mirrors -g
Now do a full repository refresh and make sure all updates we’re installed:

sudo pacman -Syyu

Some mirrors are still completely out-of-sync, You can have a look here to see all of the current mirrors status:

However, this sounds to me like maybe a plugin you have installed may be crashing Firefox.
First try running Firefox-kde without any plugins by closing it completely down and renaming the hidden ~.mozilla diectory then restarting Firefox-kde. If still getting the error try removing and re-installing the firefox-kde package itself.

Hello AJSlye,

tried all that stuff even reinstalling the firefox-kde package but nothing changed i still get the same error.


That’s strange I have Firefox-KDE on 4 different Manjaro and Netrunner Rolling machines and all of them are running fine. Are you absolutely sure your up-to-date and not using a broken mirror?

Also, how long ago did you install NR?
If it was currently (after 2015-01) did you use my initial update guide here:

Hello AJSlye,

got it working again. I had to remove the .mozilla directory AND reboot the computer to repair it. As you suspected, a plugin was the culprit. I could reproduce the error by installing that plugin and got it working by removing the plugin again. So i have to live without that plugin or hope for a new version.

Thanks again for your fast help.