[Update] 2015-05-17

Manjaro 0.8.12 update-pack 9 now online:

This is a fairly large update that Includes the following:
Framework 5.10.0
Plasma 5.3
KDE Applications 15.04.1
GTK2 2.24.28
GTK3 3.16.3
QT4 4.8.6
QT5 5.4.1
Libreoffice-fresh 4.4.3
Calligra 2.9.4
Virtualbox 4.3.28

Current supported kernels:

  • Linux310 3.10.78
  • Linux312 3.12.42
  • Linux313
  • Linux314 3.14.42
  • Linux316
  • Linux318 3.18.13
  • Linux319 3.19.8
  • Linux40 4.0.3

This update-pack also includes all regular Archlinux upstream fixes as of May 17, 2015.

Manual intervention will be required.

kcm-about-distro has been depreciated you’ll need to remove this prior to running the update:

sudo pacman -R kcm-about-distro

Also Octopi can not handle some of the package conflicts.
You will need to perform this from the command line:

sudo pacman -Syyu

Be sure to press Y (yes) at all the prompt’s.


  1. A reboot is also required due to the kernel updates.
    (If xorg hangs during reboot a ctrl+alt+backspace should resolve the issue and reboot will resume)

  2. Many of the PulseAudio modules that now have additional dependencies were split into
    separate packages. I would suggest reviewing the pulseaudio-* packages for anything you may need.

sudo pacman -Ss pulseaudio-

Official Manjaro forum feedback thread and poll: https://forum.manjaro.org/index.php?topic=22848.0;topicseen

hello AJSlye
After this update my Login screen is ok, but after login the screen resolution change to 640x480… :huh:

i try reinstalling the video driver, i have a intel i3 with HD graphic and a Nvidia 740m, but with vesa drive is the same thing…

How to repair this? I’m a bit lost and do not want to reinstall.



Have you tried going into System Settings > Display (KDE 4) or Display And Monitor > Display Configuration (Plasma 5) to change the setting there?

Which graphics chip are you using the Intel, Nvidia or both (bumblebee)?

bumblebee, but after reinstall and uninstall and reinstall again, now have and error in the monitor, does not recognize the monitor, and not start, only have the terminal, but in display and monitor dont have option to change resolution, only 640x480.

What commands did you use to re-install bumblebee?

the normal sudo pacman -S bumblebee

I think some configuration died after update…

No, that command will install it but it will not set it up.
You would use mhwd and systemctl like this:

sudo pacman -S virtualgl lib32-virtualgl lib32-primus primus
sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee
sudo systemctl enable bumblebeed
sudo reboot


optirun -b none nvidia-settings -c :8

To test nvidia 3d:

primusrun glxspheres64

To test Intel 3d:


Reference: https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup#Bumblebee_and_Steam

good, now have video again, but with the same resolution…

and …

display and monitor setting attached…

thank you very much AJSlye

Do you have more than one monitor and if so are they set to mirrored (this is the default setting).

If not then you might not have gotten a full update.
Make sure your mirrors are in sync and up to date:

then try this:

sudo pacman-mirrors -g
sudo pacman -Syyu

thanks for your reply
and no, the update was complete succesfully…
i have plasma kde… steam… another program that maybe complicate the situation?


Edit!!: jajajajjaa now after this configs i have the correct resolution options!! see attach!

What I meant is if your update was pulling from a mirror or mirrors that were out of sync, then you might not have gotten all of the packages needed during the update. pacman would still say it was successful because it did download and install what was available. I hope that made sense to you.

Yes, understand recommend leaving on the list of mirrors only those who are synchronized.

look my edit on the last post! after configs of bumblebee and 2 optirun, first with error and second successfully, i can set resolution in nvidia-setting, but after restart nothing changes… but now i have the correct resolution options in displays and monitor!

thank you very much!!! genius!!


Update went smoothly tho still have the Dolphin places/devices bug.

That is as far as I know still an upstream issue and should be addressed by Plasma 5.4

Yep still using 4.14.8 now. And still waiting for fix in KDE 4 branch

I had to do a fresh install one of my systems to learn how to use the new Manjaro-tools package. Anyway, after doing the initial update I too noticed the dolphin issue under KDE SC 4, I fixed it by deleting all the hidden folders in my home directory and copying /etc/skel back again. I’m not 100% sure what caused the issue, perhaps it has something to do with the update from baloo4 (4.14.3-2) to baloo (5.9.0-3), I think it might just be a configuration issue between the old baloo4 files and the new baloo version. I can’t test this theory since the issue is no longer present on my KDE SC 4 installation.
Maybe someone else can try downgrading baloo back to ballo4 to be sure for me.

sudo pacman -S baloo4

click yes to remove baloo when prompted.

Never mind it’s back again, this is strange. I’m going to do as I sugested above.

Nope that didn’t fix it either.

OK, right clicked and add new entry, closed and reopened and it’s fixed again, do it again and it seems to mess up, but then yoiu close and reopen and the entry’s you made are still there along with everything else.
I’m begining to think this is the old not refreshing changes issue rearing it’s ugly head again, only this time in dolphin instead of just when changing Icon sets.

Smooth update on tow systems, no troubles. However, as others have pointed out some weird behavior by dolphin/places in KDE4…