[Update] 2015-07-26

Manjaro 0.8.13 update-pack 6

In this update:
Fixes for AMD i686 on Linux kernel series 4.1.
Virtualbox 5.0
kodi 15.0
gcc 5.2
Fixes to pacman

As always this update includes also regular Archlinux upstream fixes as of Jul 26 2015

Current supported kernels:

Linux310 3.10.84
Linux312 3.12.44
Linux314 3.14.48
Linux318 3.18.19
Linux40 4.0.9 (EOL)
Linux41 4.1.3

You can use octopi or the command line to perform this update:

sudo pacman -Syyu

Official Manjaro announcement: https://manjaro.github.io/Update-2015-07-26_(stable)/
Official Manjaro forum thread: https://forum.manjaro.org/index.php?topic=24578.0

Don’t know what is going on. Right-Click system tray icon.

And select System Upgrade and nothing happens.
So I run Octopi and select system upgrade from menu. And get stuck at netrunner-desktop: requires baloo-widgets ?

So should hold off? Something amiss?

Last few updates went fine and no issues. Except the KDED file needing to be changed back for auto-mounting usb drives on startup.

So now 12:35am and time fer bed. Will check back in 8 or 9hrs.

The baloo package is the frameworks version, this should not be installed on KDE SC 4.

sudo pacman -S baloo4 baloo4-widgets sudo packman -Syu

Am running Plasma 5 migrated from 4 following thread.
When I enter first command I get.

resolving dependencies...
looking for conflicting packages...
:: baloo4 and baloo are in conflict. Remove baloo? [y/N]

And should? Y or N?

Oh well, in that case nevermind. Remove the netrunner-desktop package, then update your system, after that reinstall netrunner-desktop. Just like you did to perform the migration. http://forums.netrunner.com/showthread.php?tid=17392

I have a similar problem as Orbmiser:

[code]sudo pacman -S baloo4 baloo4-widgets

resolving dependencies…
looking for conflicting packages…
:: baloo4 and baloo are in conflict. Remove baloo? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: gwenview: requires baloo
:: netrunner-desktop: requires baloo
:: netrunner-desktop: requires baloo-widgets

So, baloo is also required by gwenview. How should I go about resolving this?

(I am still running Plasma 4)

For me Avonidas I removed just the netrunner-desktop package in Octopi and then selected system upgrade. The system upgraded then Octopi wouldn’t install netrunner-desktop back due to conflicts.

So opened a term and

sudo pacman -Sdd netrunnerarch-systemsettings-settings netrunnerarch-default-settings netrunner-desktop

And it then reloaded those 3 packages back to system. Didn’t get any errors and re-booted just fine. So hope I didn’t cause any breakage or problems down the road.

Thanks, Orbmiser, it worked fine! :slight_smile:

But I wonder, how long until something breaks? Perhaps I should updgrade to Plasma 5.

Whoa didn’t notice at the bottom you where still running 4?
Hope I didn’t lead you down the dark and dank Rabbit hole?

And had this specific breakage on Plasma 5. Been running last month or so.

Nature of the Beast as the whole KDE desktop is in flux and transition as the migration continues.
So I expect bugs to continue to rear their ugly heads from time to time. Hope it doesn’t manifest into any major breakage.

So far, so good :slight_smile:

For some reason, I had the problem in KDE 4. Your solution seems to be working fine, in the worst case I revert to using default desktop.

No that’s not going to break anything. Baloo4 is just baloo compiled for kdelibs4 instead of KDE frameworks 5, It provides the same software. The issue is that the netrunner-desktop package was built before Plasma 5 was available and hasn’t been updated since. This is just a packaging issue, nothing more.

Thanks good to know. Just these old last 2 dozen or so of neurons has problems keeping things up to date and organized. Think my Neural Gel Pack needs replacing or a replacement found on the internet!

Note: Notice in full post edit clicking on emoji icons do not insert into body of text. But shows up in top time posted frame. One with the tongue out was trying to insert into middle sentence ending.