[Update] 2015-11-09

Manjaro 15.09 update-pack 6:

Included in this update:
calligra 2.9.9-1
ffmpeg 1:2.8.1-3
kcm-msm 0.4.80.r375.a5c88aa-1
libreoffice-fresh 5.0.3-1
mhwd 0.5.6-5
qt4 4.8.7-3
qt5 5.5.1-3
xorg-server 1.17.4-2
Some Netrunner specific packages.

Current supported kernels
Linux310 3.10.92
Linux312 3.12.50
Linux314 3.14.56
Linux318 3.18.24
Linux41 4.1.12
Linux42 4.2.5
Linux43 4.3.0

This update also includes the usual Archlinux upstream fixes as of Mon Nov. 8, 2015.

You can use Octopi, or the CLI (command line) to perform this update:

sudo pacman -Syu

Muon-updater is currently broken for this update
Linux 4.3 series might be still broken for AMD/ATI users.
AMD users with opensource drivers having issues with the blacklight, please consider using the kernel from the unstable branch.

sudo pacman -U http://mirror.netzspielplatz.de/manjaro/packages/pool/overlay/linux41-4.1.13-0-$(uname -m).pkg.tar.xz

Alternatively you could downgrade to the 3.18 lts kernel:

sudo mhwd-kernel -i linux318 rmc

Official Manjaro announcement: https://manjaro.github.io/Update-2015-11-09_(stable)/
Official Manjaro forum thread: https://forum.manjaro.org/index.php?topic=28182.0

Well Netrunner Rolling follow the upgrade packs better now?
That was a major issue for me while using Netrunner Rolling before, seems like with every update pack not worked for one reason or another.

Bit confused this shows the latest but just had an update on 11-14 today?

Minor points changed my Netrunner Menu icon without asking. So changed it back to file:///usr/share/about-distro/netrunner-rolling-logo.svg. New one RUN is mickey mouse in my opinion. And doesn’t show well in slimmer width Vertical panels anyways.

And always changing my logon screen back to the star trek one and have to manually go in and delete the star trek background from the Breeze SDDM to get the default back. Also all updates seem to reset my auto-logon requiring me to manually go back and re-enable.

And still have the dual monitor glitch where sometimes one monitor just disappears and requires a logout or re-boot to resolve.

Wished updates didn’t touch my preferences and settings after every update.

Otherwise the update seems without issues that I can tell anyways.

I apologize, I pushed some files to the main repository to build the final 2015.11 ISO’s, I forgot to make an announcement about them.

This should be the last time your configs get changed, I made sure to add the etc/sddm.conf, usr/share/sddm/themes/breeze/theme.conf.user, and usr/share/sddm/themes/maui/theme.conf.usersddm.conf to the backup array so that pacman will just write pacnew files instead of overwriting. However, If you select one of the new look and feel themes and or the new netrunner sddm theme then that would be a different story. Also the Netrunner Menu Icon is the new default, this can change in the future, but as long as you already have a personal setting defined in your /.config/plasma-org.kde.plasma.desktop-appletsrc file, then this should not change on you again unless you switch the menu in and out, then your settings would have been removed from this file. The upstream Plasma developers are working on a better way to set defaults for the menus, but that will not appear until around Plasma 5.5.

PS. Big update on it’s way, Plasma 5.4.3, KDE Applications 15.08.3, Mesa 11.0.5, etc.

Thanks A.J for all the great info. And as always on top of it and sharing what’s coming.

Only major complaint isn’t a Netrunner issue but that damn pesky compositor? graphics issue.
Hoping it resolved by 5.5 which I believe is scheduled for a Dec. 8th release.

Yes, as of right now Dec. 8th is the plan.

Kwin compositor issue are actually closely tied to and usually caused by the Mesa and/or Xorg drivers.

Here hoping that December 11th 2015 - Release candidate 4/Mesa 11.1.0 will resolve the issue.

As will be in bad shape. Dec. 2nd having all my teeth upper & lower on left side ripped out.
Followed by 2 weeks then all my right teeth. Then dentures and a Merry Christmas for me Not! :s

As looks like mostly pain for the Holiday Season and No Kwin-Snow effect for Plasma 5 :-/


I’m actually anticipating Kwin+Wayland to be the cure. These is much work going into this ATM.

I have a strange problem with my Logitech G600 mouse after this update. When i press any button on the mouse, the X Windows System notices the click at the location where the mouse pointer currently is, but moves the mouse pointer to the left border afterwards. When i use a “normal” usb-mouse, everything behaves as it should do.

I tested the G600 mouse on an arch system of a collegue => same behavior.

But this problem doesn’t occur when i boot the 2015-11 live system of netrunner or on a freshly installed system from that live cd. Strange.

I installed the old version of the xorg-server and the mhwd package because they were updated within this update => same behavior

Anyone got any idea what might be the cause of this behavior or how i can get more information?

Thanks in advance

Try this:

sudo pacman -S xf86-input-libinput

Now, reboot or restart the xserver.

Thanks for your fast reply but it didn’t change anything, same behavior as before.

Check your mouse settings, other than that I have no idea. I’ve never encountered anything like that except in MS Windows, but that was the “snap to” feature in the mouse driver.

So updating 15.11 downgraded both packages? Do you know the version numbers before and after the “update”?

I think The-65 is saying that he or she downgraded these packages manually.

AJSIye got me right, I downgraded the packages on my installation manually and nothing changed. When I did a new installation from the 15-11 snapshot, the mouse worked correctly. The versions of the packages xorg-server and mhwd are the same in the snapshot and my installation, that’s why I called it strange.

This probably has nothing to do with the xorg server or mhwd.
It’s more than likely mouse settings config file issue.

I finally found a solution in the arch forums, looks like it’s a bug in upstream.

Link to the arch forum:
[size=small][font=DejaVu Sans]https://bbs.archlinux.org/viewtopic.php?id=204830[/font][/size]

Link to upstream forum

I followed the given instructions in the arch forum and “it worked for me” :slight_smile: => Problem solved

So thanks everybody for your help


No problem here all went well with the update

Wrong thread, Today’s update-pack is posted here:


Ok sorry