[Update] 2016-05-08

Manjaro 15.12 update-pack 18:

Included in this update:
kcm-msm-0.4.95.r454.3e4776c-1 [removal]
pacman-5.0.1-3 parted-3.2-4
pidgin-2.10.12-2 pinentry-0.9.7-2

Current supported kernels:

  • Linux310 3.10.101
  • Linux312 3.12.59
  • Linux313 [EOL]
  • Linux314 3.14.68
  • Linux316 3.16.35
  • Linux318 3.18.32
  • Linux319
  • Linux41 4.1.23
  • Linux42
  • Linux44 4.4.9
  • Linux45 4.5.3
  • Linux46 4.6-rc6

This update also includes the usual Archlinux upstream fixes as of May 8, 2016.

You can use Discover, Octopi or the command line for this update:

sudp pacman-Syu

Official Manjaro Announcement: https://manjaro.github.io/Update-2016-05-08_(stable)/
Official Manjaro forum thread: https://forum.manjaro.org/index.php?topic=33859.0;topicseen

Hmmm as a result of my software corruption on hardrive boot (see thread below this one)
Had massive update. Now booting up shows only 3 updates available.


No others Firefox still at 45 open a term and sudo pacman -Syu
And get everything is up to date with nothing to do.

Well, the first two I just updated in the netrunner repo’s.
expanding-icons-taskmanager-0+git20160427.651b5e2-1 (adds support for progress and status information in the tasks buttons.)
kinfocenter-5.6.3-2 (Netrunner branded upstream sysnc)

I create this list when I update on my end after the updates are released by Manjaro on the main mirror.
It could just be that the mirror your system uses may not be in sync with the main Manjaro mirror yet.

Yep was just going to wait a bit or day and see if it pops up.
No big hurries as still trying to get back to where I was a couple of days ago.
Man-O-Man! How come you didn’t tell me to make sure I had a April backup ! :slight_smile:
It’s an absolute bear getting everything back & workin the way it use to be!

Since this update, Firefox’s UI font rendering has been atrocious. I’m getting red bleeding out of black letters, which I assume means the hinting or something like that has gone horribly wrong. Disabling anti-aliasing helps with the colour bleeding, but then all the text looks like crap.

It seems to be only Firefox that’s having this problem, I have Meld, and that looks fine, so it doesn’t seem to be a GTK3 issue.

Edit: From a random link on the Internet here, I’ve tweaked my .Xresources, from:

Xft.rgba: rgb


Xft.rgba: vrgb

And that seems to have helped. The rest of my .Xresources remains the unchanged. My full .Xresources file is:

[code]Xft.dpi: 96

Xft.antialias: true
Xft.hinting: true
Xft.rgba: vrgb
Xft.autohint: false
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault[/code]

Hopefully this helps someone with Firefox UI font rendering issues.

Hmm, seems strange to me that switching the RGB (red, blue, green) setting in xresources and no where else from horizontal alignment to vertical would be a fix that would only effect Firefox.

Note: The link you posted was from 2008, I’m sure there is a better solution here:

Check your addons and make sure hardware acceleration is available and working in firefox for your GPU.
Hardware acceleration is required for proper font rendeing in Firefox.

To check type “about:support” into your address bar, press enter and look under the graphics section for GPU Accelerated Windows.
If the section shows 0/1 OpenGL (OMTC) then hardware acceleration is disabled for your chip otherwise it would show 1/1OpenGL (OMTC).

Unfortunately, the setting gfx.font_rendering.cleartype_params.rendering_mode doesn’t exist. Which isn’t that unexpected, considering ClearType is a Windows thing.

I’ve forced hardware acceleration, and that didn’t do much either.

I’ve returned my .Xresources back to its original state, and modified the anti-alias settings in Font Settings instead, and that seems to provide the same result.

Also, using VRGB is not a full solution, as horizontal lines in the UI font (and sometimes in web pages) are now red, but that’s a lot less noticeable than vertical colour fringing.

Edit: It seems Firefox changed its font rendering recently, and that went all weird for people (see https://bbs.archlinux.org/viewtopic.php?id=208110). Based on that thread, I changed my GTK font to Ubuntu 10, and the fringing is somewhat better. That said, some pages still have fringing on vertical lines. I guess the only real solution at the moment is to pick whatever looks least bad, by playing with various settings.

I’m not having this issue on any of my machines.
Are you still using the default font settings in Firefox or have you changed any of them?

I haven’t touched Firefox settings beyond force-enabling the hardware acceleration.

I’ve another machine (technically a VM) that isn’t having this issue either. It might be how the new Firefox rendering plays with the AMD driver on this one, but I can’t be sure. Either way, I’ve mostly resigned myself to finding something that’s least bad (currently that’s VRGB sub-pixel rendering combined with Ubuntu font), and hoping the rendering improves in the next Firefox release.

Agreed, that is probably the best option for now. I’ll keep searching for a solution to your issue in my spare time as well.
I’d also like to suggest filing a bug report with either AMD or Mozilla.

I have a similar problem: only with blue bleeding out vertically.

My setting is:

GPU Accelerated Windows 0/1 Basic (OMTC)

What can or should I do?


You can try to force enable the blacklisted/blocked graphics drivers: