[Update] 2016-1-13

[size=medium]Manjaro 15.12 update-pack 2:[/size]

Included in this update:
Plasma - 5.5.3 (plus additional fixes)
Firefox-kde - 43.0.4 (firefox has adopted GTK3, please give feedback)
Php - 7.0.2
Wireshark - 2.0.1
Foomatic - 3:20160105
Octopi - 0.8.0-4 (minor updates)
Qt5 - 5.5.1-8 (bug fixes)
Haskell (new packages added)
Python (new packages added)

Supported Kernels:

[]Linux310 3.10.94
]Linux312 3.12.52
]Linux314 3.14.58
]Linux318 3.18.25
]Linux41 4.1.15
]Linux43 4.3.3
[*]Linux44 4.4.0

This update also includes the usual Archlinux upstream fixes as of Tue Jan 12, 2016.

Note: Discover updater may not be used for this update due to a manual intervention requirement (upstream package change).

You can use Octopi or the command line for this update:

sudo pacman -Syu

Official Manjaro anouncement: https://manjaro.github.io/Update-2016-01-13_(stable)/
Official Manjaro forum thread: https://forum.manjaro.org/index.php?topic=30105.0

Just to let you know that Discover Updater didn’t work on this. I got the message “File conflicts occurred”. sudo pacman -Syu did work though.

Thank you for notifying us of the issue.
Unfortunately Discover uses packagekit in the background.
The problem with packagekit is that it just doesn’t handle manual interventions (conflicting packages, package name changes, separating of packages, etc.) properly.
I’ve updated the announcement to reflect this issue.

Smooth update via Octopi. And no issues detected on re-boot.

The update was smooth and no failure happened. Except that, in System Settings there are few modules that need to be removed, because they did not represent the actual ones and are duplicates of the others. I am attaching screenshot. Thanx.

We don’t add or remove anything from usr/share/kservices5/, our adjustment (reorganization) of system settings are done elsewhere. Those entries in tree view are upstream grouping settings not actual modules, these are not used by the Netrunner regrouping of system settings and why your getting those errors. Please switch back to icon view or you can just ignore those entries. What your looking for would be under Personal > Desktop Appearance.

Tree view shows all groupings and modules.
Icon view does not show unused entries or missing modules.

Thanx, I thought it was a bug. I am ignoring them…

I have noticed two problems after this update. They are:

  1. firefox-kde does not obey the system theme (Breeze Dark) in its panels at the top of the window. They are light grey rather than black, as before. Starting firefox in safemode does not seem to help. Interestingly, thunderbird-kde does not exhibit this changed behaviour. The GTK3 theme is Carbon and GTK2 theme is carbon-gtk.

  2. The default audio input device in system-settings, which was previously set to be “rear microphone” gets somehow changed to “front microphone” after the update, and thus interferes with the operation of skype, requiring manual intervention. I wonder if there is a foolproof method of setting it that does not get changed after an update. The rear microphone is also erroneously reported by PulseAudio Volume Control as “unplugged” even when left connected.

I am reporting these because they were noticed after the most recent update, but cannot be certain that they are not due to other causes. They are more inconveniences than major problems.


Firefox has changed from using GTK2 to GTK3 and thus would be using Carbon.
Try changing the Gnome Application Settings from breeze-gtk - gtk2 and Carbon - gtk3 settings to the new upstream Breeze Dark theme.
Personally, i think the the KDE Artwork team have done an excellent job on their GTK breeze themes.

Pulses audios per user settings are stored in your home directory under .config/pulse/.
However, If the issue is with the system wide defaults in the pulse audio packaging, then there is nothing that can be done.
This is an upstream arch package which does use the do not overwrite (backup) string for it configuration files, and any changes to them would be lost when updated.

Thanks for suggesting that. I installed

sudo pacman -S breeze-gtk

and selected Breeze-Dark for GTK and have the firefox panels now honouring the Breeze Dark theme. :slight_smile:

The pulseaudio settings under ~/.config/pulse comprise several files, only two of which are ASCII text, one for source and another for sink. Neither seems to have any device-specific setting like “front microphone” or “rear microphone”. My previous experience in Kubuntu has been that PulseAudio has always been fraught with unexpected behaviour after updates, and manually configured settings on PulseAudio Volume Control do not seem to persist after a system poweroff. The same appears to be happening in NRR now. Should I be changing the alsa settings on the terminal instead?

Changing the alsa settings should work, I’d say try it and find out.

I have two further comments:

  1. Changing the alsa settings did not seem to affect the behaviour of the audio input device. What is concerning, though, is that System Settings does not persistently honour the “Rear Microphone” selected as Input device in Audio Settings. It reverts to “Front Microphone” after each shutdown. I will run the most recent update to see if this goes away now.

  2. Regarding the GUI for firefox, the KDE and GTK GUIs have an annoying discrepancy: The “Cancel” button is on the left for KDE and on the right for GTK when a binary choice is presented. In previous versions of firefox-kde, this was altered so that firefox-kde followed the KDE convention. This is now not so, and makes for a lot of habit-driven errors, since firefox-kde seems to follow the GTK convention at present.

Hmm, I never noticed this about Firefox, both the firefox and firefox-kde use GTK, the difference is firefox-kde uses the Suse patches for better integration. Firefox is now using GTK3 and may be partly to blame for some of these differences. Since the Manjaro team are maintaining the firefox-kde packages, would you mind posting this issue in the Manjaro forums as well?

I have posted on the Manjaro forums as suggested. Gosh, it is a lot easier to post here than there!

EDIT: I do not see a window titled KMozillaHelper for any save operations. I have mentioned this at


but have not seen any replies there yet. So, I am posting a link here just in case it can be resolved.


Well why use Muon at all?
Octopi has its own updater that handles conflicts just fine.
Maybe the netrunner rolling edition should drop muon if its such dead weight?
I know that is blue systems baby but if it is so essential to things why have it so broken when it comes to arch style updates?
Just drop it, the things useless anyhow for a arch user.
Sorry for bringing up the old topic but it does seem like Muon is the rolling edition of Netrunners main weakness