[Update] 2016-10-23

Included in this update:
Plasma 5.8.2
KDE Applications 16.08.2
Plsama Frameworks 5.27.0
Wine 1.9.21
Virtualbox 5.1.8
Gnome 3.22.0

Note: Prior to updating your system, please make sure you don’t have widgets locked on your system. Doing so causes an issue with Netrunner Desktop, and/or folder view not pointing to the desktop location properly in your config files after update, this will cause the desktop containmant to crash with an error.

You can use Discover, Octopi or the command line for this update:

sudo pacman -Syu

Trouble shooting:
If you recive a gpg signature error for udiskie, please run the following to successfully update:

sudo pacman -Syy archlinux-keyring sudo Pacman -Syu

Official Manjaro forum thread: https://forum.manjaro.org/t/stable-update-2016-10-23-manjaro-16-10-final-release/11416/38

After updating, I’m getting the following error when the desktop tries to load:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.netrunnerdesktop/contents/ui/main.qml:341:5: Desktop.SystemSettings is not a type

That’s all the desktop shows, and I can’t even open desktop settings to change it to Folder View, because that error box seems to take up the entire desktop.

I’m not familiar with QML, so I can’t attempt to fix this myself, and the settings file for the plasma desktop is rather inscrutable. Any solutions?

Hmm, that didn’t happen here.
There we’re no errors during the update were there?

Nope, no errors during update.

Edit: Commenting out the lines related to Desktop.SystemSettings seems to have allowed the desktop to at least load normally. That’s allowed me to change the desktop to Folder View at least.

Also, anything having a Desktop.SystemSettings seems to crash; opening up the icon settings for the Netrunner desktop shows the same error, but for a different file (/usr/share/plasma/plasmoids/org.kde.netrunnerdesktop/contents/ui/ConfigIcons.qml).

Try resetting your desktop to defaults.

cp -R /etc/skel .

Something in your configs could be causing this.

I created a new user (it gets default settings, I believe) to test that out (resetting all my configs would be a pain to get it back to how I like it), and the error still pops up.

Same thing here on two different notebooks …

Fehler beim Laden der QML-Datei: file:///usr/share/plasma/plasmoids/org.kde.netrunnerdesktop/contents/ui/main.qml:341:5: Desktop.SystemSettings is not a type

Changing the desktop to desktop view or folder view should fix that.
But still, it’s so strange that I’m not getting that error.

Same error here. Changing to desktop view or folder view makes the error message disappear. But I’d rather continue using “Netrunner Desktop” like before. :frowning:

I have the same problem. No errors during the update.

I can see desktop and wallpaper, but there is a comment in the middle stating.

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.netrunnerdesktop/contents/ui/ main.qml:341:5: Desktop.SystemSettings is not a type

The folders and items I had on desktop are also gone.

I thought that to change to folder view one would: Right click on desktop -> Desktop Settings -> Layout: Folder View -> OK.

Those options are not available to me on right click. Right clicking the desktop gives: Undo, Redo, Cut, Copy, Paste, Delete, Clear, and Select All.

Any other directions I can try? I have an image file from before the update, so in worst case I can revert to that.


do you have a button in the upper left corner of your desktop? There you should be able to access the desktop settings.

All the changes we made for netrunner desktop (our fork of folder view) are now part of folder view from upstream, so not really needed anymore.

So I’ll stay with folder view and thats it. thanks for the information.

Yes, I found the button. First unlock widgets, and then select ‘Location’ and specify ‘Desktop’ folder -> ‘Apply’ -> ‘OK’. And can then re-lock widgets.

All seems to work now. Thank you :slight_smile:

Same error for me. Commenting out the offending lines helped, strangely, it was even blocking my wifi connection! (perhaps the NM applet didn’t run because of that error) Scary.

Same problem as above. Also have a Big RED circle to the left of the message with a white negative sign. I can get the message to “disappear” (it’s still there though) by changing Desktop appearance from Enlightenment to Breeze but the big Red Circle is still there. Can’t change desktop picture. Right clicking shows same as above.
cp -R /etc/skel wants a place to copy too. Don’t know where.
Should I get rid of Netrunner Rolling and go to Nurunner instead ?

No one said change the desktop theme.
To fix the issue, unlock the widgets, fix it’s location used by Netrunner Desktop and then relock the widgets (only if you want to).

Note: If you run cp -R /etc/skel in your home directory, that is where it will copy to. Remember to type y when it askes to overwrite files.

je ne peux pas mettre mon systeme a jour j ais un message d’erreur
error:failed retrieving file’aspell-fr -0.50.3-7-x86_64.pkg.tar.xz’from mirror.is.co.za:
The requested URL returned error 403

Always check your mirrors status before updating: http://repo.manjaro.org/
The African mirror is marked as unknow ATM, this could mean that it is down or has been removed.
If this situation doesn’t rectify itself on it’s own, then you may need to run rank mirrors on your system:

sudo pacman-mirrors -g

This is a known issue, you’ll need to use folder view or desktop view.