Edited by starbuck:
Read this regarding any upgrade problems:
–end of edit


I am a user that likes many Linux Versions. I have been using Linux for a few years now. I recently installed Netrunner 12.1.1. I updated after reading the forum problems with Updates Ruins the OS. Now, I figured that the updates would surely be fixed by now. Boy! Was I wrong! I even tried it twice, with each coming after two separate installs, just in case it was me. After it downloaded and was installing the updates, I saw my lower and top task bars disappear. They did not come back. So, after installs completed, I rebooted. Everything did normal progress to the Login Screen. I logged in and pressed Enter. Username and password box disappeared. The picture stayed. Nothing. I waited a long time and still nothing. The picture stayed. I tried the Advanced and Rescue and Grub Update and nothing worked.

I cannot believe this is still a problem. Love the OS. Love the Visuals. But, I am an old man and do not have time to play with broken Toys.

Please advise when it is fixed. I will try again when I have been advised. Please know it has been fixed.

I thank you for this forum and you listening to me vent.
Have very fine day,

Hello bodontknow,

did you sudo apt-get update, upgrade and dist-upgrade?
Or only upgrade?

Hi Starbuck,
No-not much in the terminal unless in Win 7 Ultimate. I did the Muon Update and it was about 450 mbs in size. It found the updates (Security; System and Applications or something along that line) and then a pop-up stated it was unable to Mark certain changes and I selected Mark Changes. All the downloads went well. As the updates installation was being done, the Task Bar top and bottom disappeared. No return. After all was finished, I restarted and no log on after username and password was typed. It hung at the wonderful Visual Display. I have reinstalled it now. Muon on Netrunner will not find any updates for some reason-now. But neither does Kubuntu. If it had found them I was going to try the updates in stages as I read in the forum to see if it would work out ok.

Thanks for your reply,

I think it could be the difference how Muon updates and if you do it by hand with apt-get upgrade, dist
-upgrade and eventually dist-upgrade again until 0 error. Also it is good to always apt-get update or otherwise refresh the packagelist before doing an update
I hope we can make sure this won’t happen in enigma, and if it does to think of ways now to fix this with a new PPA structure easily.

I agree. I just wonder how many Linux OSs have failed in this manner. I will wait for the next stable to be released around June and can wait longer if need be. Netrunner is not the only one to have same or similar things happen. I have removed all Linux OSs from all my PCs and will wait for the news this has been fixed. I love several Linux OSs (Fedora 18 KDE-Netrunner 12.12.1-Kubuntu 13.04-Ubuntu 13.04 desktop-Linux Mint 14 KDE-openSUSE 12.3 KDE and GNOME) for different reasons. Every one having its own strong points.

Starbuck, have a fine day and I will be looking and listening for good news. Your replies, even when offered to others has been greatly appreciated here.

Thanks. Actually the Mint Team is looking into this too and might come up with a solution, that will posted here once fixed. It is tested to not happen if you do apt-get dist-upgrade, so somehow muon could be responsible for the login problem, though not yet sure why.

Temporary fix if you experience the login problem:
To fix the inability to log in, drop to tty1 (CTRL_ALT_F1), and do the following:
sudo apt-get install kde-workspace-bin