Updating problem [Solved]

So far either updates were applied or no updates were found.

There are no additions to the system with the exception of adding some backgrounds.

Just ran the update manager and there were 231 packages displayed as of this instant.

All packages showed zero bites

clicked proceed

Signatures - setups - test commiting - file conflicts found

In terminal: sudo pacman -Syu

same packages found

keyring - integrity - errors occured.

System is running fine.


Did you get the updates installed?

If not then update the keyrings first:

sudo pacman -S archlinux-keyring manjaro-keyring

Then run the rest of the updates

sudo pacman -Syu

This happens from time to time, especially the Arch Linux maintainers keys.

Thanks for the tip.
Two things.
a) the keyrings did, indeed update, but no the updates did not install. :frowning:
b) I’m building a list of terminal commands and have added another! :slight_smile:

thanks again, system is still running fine.


Make sure you select Y to the file conflicts when pacman asks you to remove the previous package.
After that what is the exact error message your getting about keyring integrity?

using Updater there is no option for a Y or N, a box appears saying that there are file conflicts and one can only click ok and it disappears.

In terminal:

Hope this helps! :slight_smile:

Did you install hplip from the AUR for some reason?
Or is discover still installing updates in the background at the same time you tried to use pacman on the command line?

no I did NOT install HPLIP.

The OS found and presented the following:

A) a HP Laserjet 6P which is a parallel printer. Two drivers were presented and I chose the normal one, CUPS etc.
B) A USB HP Officejet 6600. The printer and scanner and FAX were presented and I merely chose them.

Now, the OS may have done some kind of update, when they are presented I peruse them as they are installed but I did not see anything out of the ordinary.

As to Discover installing updates in the background I have not observed such.

I turn the computer off between sessions, if they are day to day, I don’t turn it off during the day, and have only seen the above updates which do not install.

I do not observe HPLIP in the menu system or such.

I do not observe HPLIP in Discover.

I do observe HPLIP in octopi.

If uninstalling HPLIP is what is needed then I could do an uninstall and a re-install in octopi.

If CLI is needed then I would need the correct terminal commands and be glad to do it.

thanks for the help! :slight_smile:


Hplip is installed by default, I was just reading the error in your report and there are many reasons this could happen. Including but not limited to, updating or switching out hplip from the AUR manually.

Since you did not do this, and without me going into what I think may or may not have happened, please try the following commands:

sudo pacman -Syy
sudo pacman -S hplip --force
sudo pacman -Su


I am just the old woodsmoker…

When the Johnnieman was hauling terms off the beltways and I was buying synthrum and koke …

it was the time of pirates… waaay too far from the past… i mean the Johnnie man…

he was good people…

he grabbed drives and memsticks and stuff off the beltways…

I was honored to have him let me stand at his counter to let me put my hands on cold mem sticks and put them in the snapins…

might I gently suggest…that you…

ummm you…

start a thread… Sly’s tips…

As they used ta say when we were at the burn cans…'its all good…but sometimes…

just sayin…


The software on this computer is up to date.
Last checked 0 millisecond(s) ago.

as of this instant,

The software on this computer is up to date.
Last checked 0 millisecond(s) ago,

moderator, please mark this thread “SOLVED”.