back to Netrunner | back to Blue Systems

Upgrade path for Netrunner 17?


#1

So it doesn’t look like a Netrunner 18 based on Xenial is in the works?

Is there a graceful way to upgrade Netrunner 17 to Maui 1?

Since Netrunner 17’s Ubuntu Wily repositories are no longer operating I can’t just wipe all the Netrunner KDE stuff, install XFCE, then upgrade to Xenial. I guess I can just strip out all the Netrunner stuff anyway, even if it drops me at the shell, then do a standard “do-release-upgrade”, though it seems like kind of a pain. Or since I have a /home partition just do a fresh install over the top of Netrunner. I always feel like doing a fresh install is kind of a defeat, though I’m sure it saves all kinds of time in the end. A Linux distro AUGHT to be upgradeable.


#2

Netrunner 17 was based on Kubuntu (non-lts).
Maui is based on project Neon.
These two base systems are fundamentally different.
A fresh install would necessary.


#3

Wily is 15.10 and directly upgradeable to 16.04 xenial, I keep getting upgrade dialogs. I suppose I could just take one of them up and see what happens, the do-release-upgrade script will automatically disable third-party repositories. I’ll report back so other folks left stranded with Netrunner 17 can see what happened (if the admins don’t de-register me).

If it borks my system, which I expect, I’ll just install the newly released Mint 18 KDE over the top of it. Mint 18 comes with a Kubuntu backports PPA enabled, which is necessary, since KDE 5 is still pretty raw (at least the versions in Xenial Kubuntu & Netrunner 17). Mint may not come with the finely-polished eye candy of Netrunner, but it is supported for a full 5 years unlike standard Kubuntu, which is only supported for 3 years. And I don’t think Mint is as likely to abandon thousands of users without an upgrade path.


#4

It mostly went smoothly upgrading to Xenial, do-release-upgrade had problems, so I killed it and continued the upgrade using ‘apt-get dist-upgrade’ and a little bit of the force (apt-get -f install) and uninstalling some package or another. But apt became wedged because of one netrunner package that I haven’t figured out how to nuke:

Removing netrunner-system (1.1.4) …
Removing ‘diversion of /etc/pulse/default.pa to /etc/pulse/default.pa.orig by netrunner-system’
dpkg-divert: error: rename involves overwriting ‘/etc/pulse/default.pa’ with
different file ‘/etc/pulse/default.pa.orig’, not allowed
dpkg: error processing package netrunner-system (–remove):
subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
netrunner-system
E: Sub-process /usr/bin/dpkg returned an error code (1)

Sound is working, at least in Cinnamon, but I need to spend some time resolving the dpkg-divert issue before everything is working. But I’ve been using Debian/Ubuntu more than a decade, so I am confidant I can figure it out if I plug away at it for an hour or so.


#5

I just backed up the default.pa.orig file and was able to remove the netrunner-system program and unwedge apt and install kubuntu-desktop.

mv /etc/pulse/default.pa.orig /root

KDE was still hinkey, plasma would regularly fail after a bit, leaving me with no application widgets, etc., but I had that problem with Netrunner 17, as well, which is why I installed cinnamon as well, so I would have a stable alternative. So I removed most of the rest of the remaining netrunner apps (particularly netrunner-apt-config & netrunner-systemsettings-settings), though I left the wallpapers, which I rather like, and now the KDE is as good as I’ve ever gotten KDE5 to be. Why does KDE love to introduce half-baked DE upgrades to its users? It seems to take them a couple of years to work out (most) of the kinks.

Everything is pretty much working in my Netrunner 17 > Kubuntu 16.04 upgrade, but unless you are at least somewhat comfortable with CLI-fu I wouldn’t recommend it for the faint of heart, just do a reinstall of whatever you want.

I’ve got another Netrunner 17 install up in the attic, I think I’ll just blow Mint 18 KDE over it, not because I don’t think I can replicate the upgrade process, but just to see what I think of Mint’s LTS KDE. Maybe I’ll report back my impressions to this thread.


#6

Thanks for sharing. I’m stranded with Netrunner 17 on two PC (mine and the one of a friend) - and I’m still angry about the dev’s decision of cutting all the ropes for the Netrunner 17 users. If I have the time I have to figure out what will be the best successor for my friend’s PC - Kubuntu, Mint or Maui. I also trend towards Mint. Need to compare Mint and Maui on some spare partitions over a time (alas I cannot use vbox because of a limitation of my CPU). I need something with stabilty, as less updates as possible and as less changes in the GUI as possible over the longest possible time for her, preferably with the same base system I will be using so that I easily can exchange modifications.


#7

There is an upgrade script in the making for Netrunner 17 users which should allow upgrading to the xenial base.

This will not upgrade to the Maui Neon base (as this needs a lot of tinkering) but should bring you to the LTS Ubuntu Xenial base which is supported further onwards.
We don’t want to leave somebody out in the rain.


#8

That’s good news! Thank you!


#9

This is good. I did install Maui on my Netrunner 14 pc but am not wanting to replace my Netrunner 17 with it. However, I haven’t found anything else I want to replace it with, either. Netrunner is a hard act to follow and I will miss is. This will give me a little more time to look around, or possibly for Maui to improve, before I have to decide what to do.


#10

Update: Release announcement about Upgrade script is out now. Feel free to discuss here or in a new thread if you encounter problems or have questions.

http://www.netrunner.com/upgrade-script-netrunner-17-ubuntu-xenial-16-04-lts-base/

Note: You might notice in the script there is an outcommented part with experimental instructions for upgrading Netrunner 17 to Maui 1. These are really experimental and I encourage only to try this out with a working backup (snapshot of some sort either LVM or btrfs) and if you have experience dealing with fixing stuff when apt complains about package overwriting conflicts. This is officially not supported and might break at any minute.


#11

I finally updated my Netrunner 17 to Ubuntu 16.04. Works so far, had to reinstall Plymouth, Amarok and some other parts.

I noticed that some systemsettings modules (Appearance and Splash so far) go black when I want to open them after I have clicked on the part for the window decorations. I have to close and reopen systemsettings to be able to access those modules. I can live with it.

And in dolphin I have lost the preview for cursor files, it is just no offered anymore in dolphin’s settings for the previews. Which package could that be so that I can get the previews for the cursors back? It’s important for adjusting cursor themes…

BTW: Where do I now have to ask for help? Here in the Netrunner 17 archive, in the Maui forum or do I have to go to some Ubuntu forum without telling them it is not a pure Ubuntu?


#12

This is correct forum to ask for help.

The going black in systemsettings might be a compositor issue with your graphicscard. Try changing the compositor settings like setting a different OpenGL version.

For the cursor preview I honestly don’t have an idea. I don’t think there was an explicit preview option in the settings -> general -> preview.
Have you tried checking there svg for example?


#13

Converning the cursor previews:
I’m pretty sure there was that dolphin option. I executed “ktraderclient --servicetype ‘ThumbCreator’” which shows me (among others)

---- Offer 6 ---- CacheThumbnail : 'FALSE' Type : 'Service' Name : 'Cursor-Dateien' Invalid property Comment Invalid property GenericName Invalid property Icon Invalid property Exec Terminal : 'FALSE' Invalid property TerminalOptions Invalid property Path ServiceTypes : 'ThumbCreator - image/x-xcursor' AllowAsDefault : 'TRUE' InitialPreference : '1' Library : 'cursorthumbnail' DesktopEntryPath : 'cursorthumbnail.desktop' DesktopEntryName : 'cursorthumbnail' Keywords : '' Categories : ''

I do find cursorthumbnail.desktop on my system, but only for the KDE4 part: /usr/share/kde4/services/cursorthumbnail.desktop
It belongs to the package kde-runtime-data. The services for Plasma 5 are in the package kio-extras-data and cursorthumbnail.desktop is not included. i tried copying /usr/share/kde4/services/cursorthumbnail.desktop to /usr/share/kservices5/ and now have the option in dolphin’s settings - but alas there seems to be missing something else, I don’t have the thumbnails either…


#14

It needs more than a desktop file as this only gives the setting. It needs the library itself which is the .so file.
I don’t think there is a cursor thumbnailer for KF5/Qt5 yet.


#15

You are right, just a desktop file doesn’t make the fish swim - but i was hoping the libs were there nontheless… In Maui cursortheme.desktop is available in /usr/share/kservices5/ … so probably it is a problem of the kio-extras-data version…


#16

That cursortheme.desktop is the kcm (systemsettings) entry.


#17

I tried the update script too, and am having some really annoying problems.

  1. Frequently, on waking from sleep the wifi can’t connect. It not only can’t connect, it can’t even see any wifi networks. Logging out and back in doesn’t help. I have to reboot the computer to get it to see the networks and then it connects.

  2. It can’t see my touchpad anymore. The cursor jumps all over the screen making typing nearly impossible at times. Sometimes I can’t control the cursor and have to use a mouse. It seems to come and go. I went into settings to see if palm detection had gotten turned off somehow and it said no touchpad detected.

Any help for these?


#18

Nevermind. I think it’s time to replace it rather than try to fix it. I was hoping to buy myself enough time to find something else I loved but it’s time to decide on something.


#19

Another problem occured: I cannot install pepperflash? The package installs but it doesn’t deliver libpepflashplayer.so?

“sudo apt-get install pepperflashplugin-nonfree browser-plugin-freshplayer-pepperflash” ends with

[code]45000K … … 100% 1,03M=41s

2016-12-09 14:22:35 (1,07 MB/s) - »/tmp/pepperflashplugin-nonfree.M0mfYqgDKo/google-chrome-stable_55.0.2883.75-1_amd64.deb« gespeichert [46092946/46092946]

mv: Aufruf von stat für ‘unpackchrome/opt/google/chrome/PepperFlash/libpepflashplayer.so’ nicht möglich: Datei oder Verzeichnis nicht gefunden
browser-plugin-freshplayer-pepperflash (0.3.4-3) wird eingerichtet …
[/code]


#20

Found this https://bugs.launchpad.net/ubuntu/+source/pepperflashplugin-nonfree/+bug/1632870, seems to be broken per se and adobe-flashplugin should be used.