back to Netrunner | back to Blue Systems

Upgrade to 17.01

Here is a How-To upgrade from 16.09 to 17.01:
http://www.netrunner.com/upgrade-netrunner-desktop-16-09-to-17-01/

Please post here for any issues or questions.

3:48 hrs install time on a Lenovo G570 (i3 2nd gen) with a 20Mb cable connection.

Upgrade seems to be okay, with the exception of 1 (for now) previously installed program;
MoneyManagerEx which has the following error; “Unable to run the command specified. The file or folder /usr/share/applications/mmex.desktop does not exist.”

FYI: The Desktop icon “Readme” link points to 16.09, but with a quick edit of the “Command” line in “Advanced” of the program “Properties” from;
firefox http://www.netrunner.com/readme-desktop-1609
to;
firefox http://www.netrunner.com/readme-desktop-1701
will fix that. [i]Please note, firefox is my default browser, others may vary.
[attachment=1020]

Update: I reinstalled the MoneyManagerEx program using the mmex_1.2.7~xenial5_amd64.deb Ubuntu package from http://ppa.launchpad.net/dwrj87/mmex-test/ubuntu/pool/main/m/mmex/
[/i]

Thanks for the feedback!
That seemed to have taken rather long, I tested here on an old Acer machine with magnetic harddrive and 1MB line and the full update took about 1.2 hours.
Still glad to hear that it run successfull on your side.

You’re welcome & thanks for the help!

Also, after reviewing info found here; http://askubuntu.com/questions/829370/n-ignoring-file-50unattended-upgrades-ucf-dist-in-directory-etc-apt-apt-con

I removed file ‘50unattended-upgrades.ucf-dist’ in directory ‘/etc/apt/apt.conf.d/’
Then I ran “sudo apt autoremove” & it found over 450+ unused packages left over from the upgrade from 16.09 to 17.01.
This seems to have cleared up another issue I had installing digikam. Ref; Digikam 5.3 unmet dependencies #4 (Update)

Ah good to know!, we will add this to our intructions!

Tried running upgrade and got: “mv: cannot stat ‘/etc/apt/sources.list.d/netrunner-backports.list’: No such file or directory”
Should I remove that line and continue on, since it’s only making a backup of a file I apparently don’t have?

Hi
That does seem a bit odd, but yes, you can remove that line and you should be fine.

Okay, I removed that line and the others that renamed the source files (since they were already renamed previously), and all the packages went through, downloaded and unpacking, until about an hour later, it’s gotten stuck on this loop:

E: Package ‘skype:i386’ has no installation candidate

  • sleep 5
  • true
  • apt-get -d --reinstall -y -f --force-yes -o Dpkg::Options::=–force-overwrite,confnew install netrunner-desktop linux-image-amd64 linux-headers-amd64 skype:i386
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Package skype:i386 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

E: Package ‘skype:i386’ has no installation candidate

  • sleep 5

I never had Skype installed, nor do I want it to be. I’m not sure what to do, since it won’t get past this. I might have to stop it.

Hi
You can run the following commands manually to finish your upgrade:

APT_OPTS='-y -f --force-yes -o Dpkg::Options::=--force-overwrite,confnew' apt-get --reinstall ${APT_OPTS} install netrunner-desktop linux-image-amd64 linux-headers-amd64

Upgrading from 16.09. on my desktop machine went fine.

However after the upgrade window drawing and everything else that is slightly related to graphics, is very sluggish and slow.

I’m using an ATI graphics card:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X]

It seems that the graphics driver has fallen back to something weird:

OpenGL vendor string: VMware, Inc. OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits) OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.2 OpenGL core profile shading language version string: 3.30 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.0 Mesa 13.0.2 OpenGL shading language version string: 1.30 OpenGL context flags: (none) OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.0 Mesa 13.0.2 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

Any ideas how I can fix this?

Upgrade and tidy up ran OK. Restarted.

Then, in Synaptic, I tried to install Skype:

Cannot install Skype, “Could not apply changes, fix broken packages first”

So, Run Fix Broken Packages

E: Unable to correct problems, you have held broken packages. E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies

How do I fix this?

When I originally installed 16.09 I had similar problems with a long list of deal-breaking packages so had to abandon Netrunner for Maui. Now I’m revisiting Netrunner in hopes that Skype will work, which it didn’t, and still won’t in Maui (but does in Netrunner 14). I had hoped that this upgrade, and then to 17.03, would fix both problems.

Skype itself is outdated anyways and won’t work next month.
I would suggest downloading the skypeforlinux beta from the official Skype website if you still need skype or use the Web version which is appr. the same currently.

I have tried Skype for Linux in Maui, but the problem is the same - mic not picked up. I must check out the web version.