With some delay I had now a chance to upgrade my computer.
The experience was not good, and I would suggest not using the method above for anybody who used their Netrunner 21 for a long time. I don’t know exactly what’s different from a clean setup, but after upgrading all my repositories to point to new software, the process said “clearing obstacles for update”, then crashed on me going back to terminal and saying
ERROR 404: Not found.
I am currently probably in a fraken-debian situation, and will be reinstalling from scratch.
I tried manually finishing the upgrade by reading the source of the update script.
The 404 errors come from having hard-coded some package urls around netrunner-update-tool · main · netrunner / Utilities / netrunner-update-tool · GitLab
In particular, these are
gcc-12-base-i386.deb "http://ftp.us.debian.org/debian/pool/main/g/gcc-12/gcc-12-base_12.2.0-14_i386.deb" \
gcc-12-base.deb "http://ftp.us.debian.org/debian/pool/main/g/gcc-12/gcc-12-base_12.2.0-14_amd64.deb" \
libc-bin.deb "http://ftp.us.debian.org/debian/pool/main/g/glibc/libc-bin_2.36-8_amd64.deb" \
libc-l10n.deb "http://ftp.us.debian.org/debian/pool/main/g/glibc/libc-l10n_2.36-8_all.deb" \
libc6-i386.deb "http://ftp.us.debian.org/debian/pool/main/g/glibc/libc6_2.36-8_i386.deb" \
libc6.deb "http://ftp.us.debian.org/debian/pool/main/g/glibc/libc6_2.36-8_amd64.deb" \
libgcc-s1-i386.deb "http://ftp.us.debian.org/debian/pool/main/g/gcc-12/libgcc-s1_12.2.0-14_i386.deb" \
libgcc-s1.deb "http://ftp.us.debian.org/debian/pool/main/g/gcc-12/libgcc-s1_12.2.0-14_amd64.deb" \
Not sure if this is the best way to retrieve these, even if the script should probably try to fetch them before starting the upgrade and having to quit it traumatically half way through! I just manually fetched and installed the versions coming right after the ones listed, and it went smoothly.
Anyway, I kept running apt commands manually, and was able to execute most except
I had some trouble with the Steam repo keys, I just removed those, I don’t use Steam.
I have ended the process (except for those packages above that fail, mostly they claim that they depend on dependences that cannot be met, like “it depends on python3.10 but 3.11 installed”). I will now venture in rebooting the machine, who knows what shows up next!
The system managed to reboot, which quite pleasant to see!
I tried reinstalling the packages that failed, and some managed. The current list of uninstallable packages is
Some of these puzzle me, such as
hplip : Depends: libhpmud0 (= 3.21.2+dfsg1-2) but 3.22.10+dfsg0-2 is to be installed
Depends: printer-driver-hpcups (= 3.21.2+dfsg1-2) but 3.22.10+dfsg0-2 is to be installed
Depends: python3-reportlab but it is not going to be installed
Depends: python3 (< 3.10) but 3.11.2-1+b1 is to be installed
(how can there be something depending on python3 < 3.10 on the repos, when 3.11 also is??)
Some kinda worry me more:
The following packages have unmet dependencies:
systemd : Conflicts: systemd:i386
systemd:i386 : Depends: libacl1:i386 (>= 2.2.23) but it is not going to be installed
Depends: libapparmor1:i386 (>= 2.13) but it is not going to be installed
Depends: libaudit1:i386 (>= 1:2.2.1) but it is not going to be installed
Depends: libcryptsetup12:i386 (>= 2:2.3) but it is not going to be installed
Depends: libip4tc2:i386 (>= 1.8.3) but it is not going to be installed
Depends: libkmod2:i386 (>= 5~) but it is not going to be installed
Depends: libpam0g:i386 (>= 0.99.7.1) but it is not going to be installed
Depends: libseccomp2:i386 (>= 2.4.1) but it is not going to be installed
Depends: libsystemd0:i386 (= 247.3-7+deb11u2)
(“systemd : Conflicts: systemd:i386”?? Yikes!)
Anyway, it’s good to know the laptop still boots. I was going to attempt the update, but really I can afford reinstalling, so I’ll probably move on to that when I have a free evening and some series to binge-watch.