USB drive not showing in Dolphin

I am running Netrunner 14.2 LTS 64-bit with KDE and my Sandisk Cruzer Edge 8GB USB drive does not show up in Dolphin when I plug it in.

lsusb shows it is there.

demesg shows it as /dev/sdb:

[32983.231840] usb 3-1: new high-speed USB device number 5 using xhci_hcd [32983.248375] usb 3-1: New USB device found, idVendor=0781, idProduct=556b [32983.248385] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [32983.248390] usb 3-1: Product: Cruzer Edge [32983.248394] usb 3-1: Manufacturer: SanDisk [32983.248397] usb 3-1: SerialNumber: 20051737710CEB125179 [32983.269975] usb-storage 3-1:1.0: USB Mass Storage device detected [32983.270121] scsi6 : usb-storage 3-1:1.0 [32983.270296] usbcore: registered new interface driver usb-storage [32984.268938] scsi 6:0:0:0: Direct-Access SanDisk Cruzer Edge 1.26 PQ: 0 ANSI: 6 [32984.269549] sd 6:0:0:0: Attached scsi generic sg1 type 0 [32984.270521] sd 6:0:0:0: [sdb] 15633408 512-byte logical blocks: (8.00 GB/7.45 GiB) [32984.275752] sd 6:0:0:0: [sdb] Write Protect is off [32984.275762] sd 6:0:0:0: [sdb] Mode Sense: 43 00 00 00 [32984.276683] sd 6:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA [32984.283478] sdb: unknown partition table [32984.305922] sd 6:0:0:0: [sdb] Attached SCSI disk

fdisk -l /dev/sdb shows:

[code]Disk /dev/sdb: 8004 MB, 8004304896 bytes
247 heads, 62 sectors/track, 1020 cylinders, total 15633408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/sdb doesn’t contain a valid partition table[/code]

I would like to write a Netrunner .iso to this usb to try out but I think based on my limited knowledge that this usb stick needs some partitioning done?

Thanks and let me know if you need more information.

I’m not a USB expert, but this link (at the linux part at bottom) usually helps me:

You can use the kde partitionmanager to create a new partition table on the stick.
If you only want the ISO to be written onto it use dd.

Like for example so:

sudo dd if=/path/to/netrunner.iso of=/dev/sdb

Thanks for the tip. I will look into pendrivelinux.

Thanks leszek, I am familiar with dd which has worked well in the past.

Do you know how to partition the usb drive so it will show up in Dolphin? My goal is to also be able to view the contents of the usb drive in dolphin after I insert the stick. Right now, nothing happens when I insert it whereas when I insert other usb stick they immediatley pop-up in Dolphin.


For that you need to use a different boot method and a different method to create the live usb stick.
First use the partition manager to create a fat32 bit partition (I would recommend to use this for the whole stick)
Then you can use a tool like unetbootin to create the live usb stick.
In details it will extract the ISO onto the fat32 part of the stick and will install syslinux for it to be bootable.


As usual, your solutions are fast, easy and they always work! I just partitioned the whole stick using partitioner manager and it is now immediately recognized in Dolphin. dd worked great for the .iso transfer and it boots perfectly.

Thank you as always!