VirtualBox quit working after update [SOLVED]

I just competed the update, and everything was updated successfully. How ever, my VirtualBox quit working after the upgrade. It says “Aborted” when I try to launch Windows 7. The system upgraded the Virtualbox to 4.3.16, and upgraded my kernel to 13.14.18-1. I don’t what to do now. Please advise.

The host and guest modules have been split into separate packages.
You’ll now need to install the host modules package for your kernel:

sudo pacman -S linux314-virtualbox-host-modules

This should also help you out:

It’s still not working. It was working fine prior to the update. I’m rethinkng the Rolling, and may be going back to Frontier.

Does Windows 7 give the error that says aborted or is it virtualbox?

Did you reboot after installing linux314-virtualbox-host-modules for the new modules to load?

You may also need this:

The official VirtualBox Guest Additions ISO image
Replaces virtualbox-additions virtualbox-iso-additions[/quote]

sudo pacman -S virtualbox-guest-iso

If you installed the virtual box guest utils in Windows 7 they will need to updated as well.

I figured it out. I had to download the VirtualBox 4.3.16 Oracle VM VirtualBox Extension Pack from Orecle’s website, or upgrade the extension pack. I upgraded the extenion pack and got it to working again.

Thanks as always,

OK, so it wasn’t completely the Rolling Editions fault then. LOL :slight_smile:

No, but these are unwanted consequence with a Rolling version. One or two program may not work, like in this case. I’m sticking with it to see how long this relation is going It’s like having an unpredictable girl friend! :slight_smile:

Yea well to be fair, anytime you update virtualbox itself you have to update the host drivers and client side software as well.

For the most part the update packs from Manjaro have been stable, I’ve only had the rare instance when something is majorly changed in packaging, which is what happened in this case. I do have to agree that even though most of the update packs from Manjaro have been simple and straight forward, occasionally manual intervention has been required, however this is far less often with Manjaro than if we we’re running on a pure Arch base.

I’d also like to mention that in my experience programs can still break even under “Stable Distributions” like Ubuntu.

I’m Just sayin’. :wink:

I agree, but it seems like the Frontier on the other hand is more mature, and stable. I am running Frontier on my laptop (with VirtualBox, and Windows 7), and also on my wife’s laptop. You hardly have to mess with it. I’m just going to hang tight and try it for a while, and see how long this relationship lasts. Another strange thing is that I never had any compatibility issue on my desktop when I was running Frontier, as far as freezing or not shutting down. This is the first time that I ever had to use the terminal to turn off the computer, running Rolling! :slight_smile:

If you Have better results with the Ubuntu base on that machine then by all means use that, sometimes one machine can be more finicky than another. I have never had that issue either, that is what makes this extremely hard for me to figure out. I have been running Manjaro on 6 totally different machines now for over a year now, and have had very little issues with any of them. I only recently decided to give the Netruuner another try only because of it’s Rolling versions Manjaro base, when I had tried Netrunner previously I had a few issues with it that I didn’t have on Kubuntu Itself at that time. My wife can’t stand KDE and has always been a Gnome user (well up until 3.0 that is), but now she uses Cinnamon and loves it, my sons netbook on the other hand needs a light weight DE so he has Mate on it, this is why I always tell people to use what works for them. Also keep in mind that on a distribution like Ubuntu with thier long release cycles, if there is an Issue with it on certain hardware sometimes it may not get fixed until the next release or the next release could break something itself that again wont get fixed right away, I have a laptop that to this day no longer works with Fedora or Ubuntu dince teo years ago, but works beautifully with Manjaro and OpenSuse, I don’t know why but it just does.

Anyway, I’m glad your going to give it a bit longer, and I do apologize for getting so long winded.

Hi AJ,
Thanks for your input. I don’t give up that easy! :slight_smile: