VMWare Player

I’ve installed VMWare Player many times in the past on several Linux distros and on Windows and the installation was very easy and straightforward. However, I’ve just tried to install it on 2015.11 and immediately I have a problem because the installer is asking me for the “System service scripts directory (usually /etc/init.d)”. That directory doesn’t exist on 2015.11 so I’m a bit stuck as to what to do. I’ve read the ArchLinux Wiki here: https://wiki.archlinux.org/index.php/VMware and it makes mention of this very problem, so do I just go ahead and do what it says? And what about the services it mentions, do I have to do all that as well?

Yes, you just need to follow the Arch wiki.

Personally, I would recommend installing the optional systemd services package from the AUR.

Thanks for that, followed the wiki, here’s how it went:

  • fuse was already installed
  • installed gtkmm
  • installed linux42-headers
  • tried to install ncurses5-compat-libs but I got this error:

==> Verifying source file signatures with gpg... ncurses-6.0.tar.gz ... FAILED (unknown public key 702353E0F7E48EDB) ==> ERROR: One or more PGP signatures could not be verified! ==> ERROR: Makepkg was unable to build ncurses5-compat-libs.

What now?

Update your key-rings:

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

However, this could just be an issue with the AUR pkgbuild file.

OK i just looked at the pkgbuild, all this does is install ncurses 6.0 and symlinks to the libs for compatibility.
Since ncurses 6 is already installed, you could just create the symlinks yourself.

This is the result of updating my key-rings:

[martin@sgc ~]$ sudo pacman-key --init [sudo] password for martin: [martin@sgc ~]$ sudo pacman-key --populate archlinux manjaro ==> Appending keys from archlinux.gpg... ==> Appending keys from manjaro.gpg... ==> Locally signing trusted keys in keyring... -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8... -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2... -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E... -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC... -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8... -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6... -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77... -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887... -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894... -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2... -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268... -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0... -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E... -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7... ==> Importing owner trust values... ==> Disabling revoked keys in keyring... -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6... -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55... -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50... -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350... -> Disabling key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17... -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5... -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2... -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992... -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196... -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366... -> Disabling key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E... -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D... -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477... -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84... ==> Updating trust database... gpg: next trustdb check due at 2016-01-22 [martin@sgc ~]$ sudo pacman-key --refresh-keys gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: IPC connect call failed gpg: keyserver refresh failed: No dirmngr ==> ERROR: A specified local key could not be updated from a keyserver. [martin@sgc ~]$

Oops, I forgot about that issue:

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo dirmngr < /dev/null
sudo pacman-key --refresh-keys

Oh yea, if your going to use vmware instead of virtual box, you may want to uninstall the vbox host kernel modules.

OK, I’ve done that but I’m still getting the signature error but, after looking at the PKGBUILD, the clue is at the very top of the file so I’ve now done this …

gpg --keyserver pgp.mit.edu --recv-keys 702353E0F7E48EDB gpg --lsign 702353E0F7E48EDB

… and the package now builds.
I will now attempt to install VMWare Player again, stay toooooooned :smiley:

Man, I can’t believe I didn’t notice that validpgpkeys= line in the pkgbuild file itself.

Well, you should get some new glasses, then :cool: :cool:

Ran the installer again and entered /etc/init.d when asked for the System service scripts directory and I eventually got the following warning:
Then clicked OK and, after quite some time, the installer informed me that the installation had been successfull.

  • Installed vmware-systemd-services (from AUR)
  • Then did this:

sudo systemctl enable vmware sudo systemctl enable vmware-USBArbitrator

  • Fired up VMWare Player and opened an existing VMWare image.

I can’t see any problems so I’m assuming that everything is as it should be :smiley:

Are you using vbox as well?
If not you may need to remove the the vbox-host kernel modules:

sudo pacman -R linux42-virtualbox-host-modules

This is supposed to be installed by default, If it is not please let me know.

The package is installed and I have no intentions of ever running VBox but would it do any harm if I didn’t remove the package?

No, It’s just a kernel module that’s being loaded into ram, it doesn’t take up too much in resources.
We installed this because virtualbox and virtualbox-guest-iso are also installed by default as well.

It’s really up to you. :slight_smile: