Volume Control Not Working Right...

Got another one for ya!

When I clicked on the volume icon in the panel just now,
It brings up a small black popup window, but there is
nothing in it.

ScreenShot attached:

First, make sure this is not just a theme issue: System Settings > Desktop Appearance > Desktop Theme

Otherwise since that is the icon for veromix, which works independently of phonon, right click on it and select Veromix Settings, make sure the right Sound Card Profile is selected in the Pulseaudio section:


If all else fails, disable veromix and activate kmix control here:


Also make sure you have the right sound card selected in phonon: System Settings > Audio > Audio Hardware Setup
By the way, I’ve never had very good luck with veromix, for me it crashes a lot so I have uninstalled it.

None of what you list above is showing. I don’t even remember that changing, although I think it’s probably only been a couple of days.
No veromix anywhere and all that shows in the audio settings is the built in analog audio. That’s it.

I haven’t changed any theme since installing this OS. But really… all I did then was change the wall paper to Dream Desktop.

I do like the looks of the icon much better, though.

You’re using Dream Desktop, well that explains that then. You need to either turn on native composting and use an OpenGL setting compatible with your GPU or change your desktop back to the Netrunner Desktop setting and see your Veromix volume control again. As far as my Icons they are just the KFaenza icons.



I have had dream desktop running since I installed this OS! I only started having issues recently and the volume icon I think has been there for only two days. What’s the sense of offering this in the OS if it corrupts the thing??

I did what you suggested and the volume pop-up window is still blank.

That’s strange, I’ll research this a bit more tomorrow and report back what I find.

For now right click on the System Tray and select System Tray Settings > Display and remove the check-mark from Veromix, next click on Entries and set Volume Control to Auto and apply then OK, you should now have the kmix volume control in the tray.