Volume keys not working [SOLVED]

Just a very quick annoyance too - I can’t work out what exactly is missing but my volume keys on my keyboard no longer work. I can’t for the life of me work out what has been removed. It’s driving me mad, please help.

Is kmix running ? It only changes volumes if kmix is running.

yep but the keys are just not being recognised. I’ve tried running xev and all the other keys are recognised except the volume keys & calculator key

Hmm… to bad. If xev does not detect anything when pressing the key than I am out of ideas on howto configure it.
Was it working before ?

yep, was working in Netrunner 13.12 - same keyboard type selected ‘Generic 101-key PC’, same keyboard layout… I am utterly baffled

So it never worked on Netrunner Rolling ?
Maybe its because of the newer Xorg package.

But as I said before if xev does not detect anything I think I can’t help you make it work.

I can’t remember if it was working before I did the first package upgrade or not. Do you know if xorg captures the keyboard input and sends it to the mixer or is some other package responsible for capturing?

Xorg captures the key normally thats why xev should normally show something that it captured. But if it does not tell anything its not even knowing your are pressing the key which is the problem here as then kmix and others won’t notice that you pressed it.

Is this a laptop mediabar above the keyboard?

If so remove the battery & unplug the laptop, wait a few minutes and plug the laptop back in (leave the battery out at first) and start the laptop, the mediabar should now work…

On some laptops (mostly HP’s) when the battery first starts to go bad (holding less charge) static from it will short out (not for a better term) the mediabar.

Nope, it’s a desktop computer with a Microsoft Wired Keyboard 600. I am stumped.

Might I suggest booting up a Netrunner standard CD and see if it works?
If it doesn’t then the keyboard may have went.
If it does work please let us know so the developers might find the file or setting that has changed.

I’ve just done as you suggested and the multimedia keys work fine, tried rolling livecd and they didn’t, I’ve tried comparing what services are running etc but I just can’t find what is wrong.

I think I may have found a solution, try removing xf86-input-joystick

sudo pacman -R xf86-input-joystick

look here:

AJSlye - you sir, are a gentleman and a scholar, it worked. I am eternally grateful to you. I have been trying to get this fixed for about 3 days and tried everything I could think of. Thank you ever so much. You are a legend :slight_smile:

You are very welcome brother, I’m joyful that I could help…

Glad I found this thread. And thanks for the solution AJSlye

sudo pacman -R xf86-input-joystick

Posted here as was having the same issue today Jan. 13th 2015 9 months later. So nobody updated the repo to keep this from being installed? As solved my issue of multimedia and OSD voulume on screen not working by removing offending package. Just wondering why it’s still being installed if not needed and causing issues with some users.


I posted a response in your thread. :slight_smile:

Go to start then multimedia click on Kmix to sat up audio and then click on setting select master channel and select one of current mixer for your card or which is best.

The problem had nothing to do with how the audio card is set up in Plasma.
I am however wondering, why you’re posting in an already solved thread?


If you red this could you move (Solved) to the beginning of your threads title?
This would insist in avoiding any misunderstanding over the current status of the thread.