Volume Reset to Max

A minor issue but an annoying one;

I’m running Netrunner in a VM on unRAID 6 with a GPU and USB controller passed thropugh.

Attached to the USB controller, I have a set of SoundSticks speakers. These work great with one exception;

Whenever I boot NetRunner, the volume resets to maximum and the startup chime blasts out.

Anyone know of a way of making the volume state stick between boots?


You can set the volume and execute

 sudo alsactl store

to forcefully store the current volume settings in alsa. These should be restored on reboot.

If you set the volume in the system tray it should stick between VM’s, but it won’t always match your host systems volume. I hate to ask but, did you install Netrunner into the VM or are you loading the Live ISO file each time you use the VM? I had someone ask this before and that’s what they were doing.

So that’s how I would expect it to work and how it did work when I ran Netrunner under unRaid/Xen. Only when I recently moved to KVM has this issue appeared. (though that coincided with some substantial NR updates so that could be the reason as well)

There’s no issue with matching host systems - the audio device is passed through to the VM so it’s completely independent of the host (there is in fact no audio on the host system at all).

Netrunner is correctly installed to a 30GB disk image and the ISO has been removed from the config files.

I’ve tried leszek’s suggestion - hopefully that will do the trick.


Closing this out, [color=#363636][font=’]leszek’s suggestion worked perfectly.[/font][/color]