VPN not working

Hi, I have just installed netrunner RR on virtualbox to test it, I am a Manjaro user and I have to say taht Netrunner is amazing!!
I am trying to set up a connection with my vpn provider (private internet access) using openvpn. After connecting, I check my IP address and I still have my real one. I realized that a new tun0 connection is created every time I connect using vpn. I have never seen this when I used other openvpn connections using openSUSE 13.1 or linux mint 17: with them, I can connect directly without the tun network, so I thought that maybe the problem is related to that.
Please help me!! This is the only negative thing I have found so far with netrunner.
Thank you

openvpn on Manjaro/Arch might be setup differently by default or maybe the Network Manager settings might be different.
You may also need to set up openVPN yourself to use a tap device instead of a tun device.

Here is the openVPN arch wiki:

openVPN web site::

and network-manager:

This the process I used with Manjaro KDE:


I would be interested to see what your setup process was askorbeta.

Dear davidbrooke,
thank you very much for your tutorial. You are really nice.
I have followed it (KDE gui; first “Import” method, later “Manual”), but when I open whatismyipaddress.com, my IP is still the same as without VPN, even if I’m apparently connected to it (I also use privateinternetaccess). I don’t know what is wrong. I have also tried to change manually the dns servers, but still the same.
Everytime I connect to the VPN, a new tun0 network is created, which is something I don’t see when I am using openSUSE13.1 or Mint17 for testing purposes. Could it be the reason? I have no idea. Using the CLI method could fix the problem? Do you (or anypne) have any other wise advise? I would really appreciate it.
Thank you. Best regards,

  1. Try the CLI method, the non-systemd is the easiest. This way you can find out if there are any other issues like username, etc…
  2. When you used the Manual method:
    A. Did you create a new connection or edit the existing connection that was created when you used the Import method?
    If so please create a new connection and try the Manual method again.
    B. When using the Manual method, only do the steps I have outlined A - G since you are using Private Internet Access. Do not enter any other info like the gateway port number. I found if I enter the gateway port it doesn’t work.

Dear davidbrooke,
I first tried the CLI method as you suggested (but the systemd method) and worked!! :slight_smile:
I was curious to know why the CLI but not the GUI method worked, and I have been doing some comparisons. I have realized that using the “Import” GUI method, the pathway for my ca.crt file is automatically changed (from my home folder where I unzipped it, to another one: ./kde4/local…something else, sorry, I didn’t write it down). I don’t know if this can explain something to you (I don’t have the skills to understand it), but for me is intringuing… Hope this could help.
Thank you very much for your help.

I think you may have just found a bug in plasma-nm.

Please also try the manual method.

I’m very glad to here you got it working askorbeta.

the manual method also works well, I tried it again and this time it works, it doesn’t change the path for my certificate file.