Webcam not recognised


I just installed Netrunner and am very impressed. Slowly trying out everything and adding the things I need. Wine and Quicken went without trouble. Today I logged into Skype and found that the webcam of my Asus Ultrabook is not recognized. It did work fine with Open Suse that I had installed earlier.

Any hints of how I can get it to work? Where to start? Also under sound, in System settings it does not show up.

Thanks so much.

Welcome to the Netrunner Rolling (Manjaro/Arch) forum.

Please read the Netrunner Rolling read me and update your installation before proceeding:

Now, Which Ultrabook model do you have?

You can try Fn+v as this toggles the webcam on and off on some models.

Reading the readme now… In the mean time the model is: ASUS ZenBook UX31A-R5102F 13.3" FullHD
The Fn+v is indeed to turn the camera on and off but it does not seem to do anything.
All multi media keys fn+ f1 to f12 work fine, including keyboard back-light and all.

I did the update already after installing few days ago but did again with the message in the end ‘there is nothing to do’

What would be the next step?

look what I found:
According to this wiki for fn+v to work a keyboard shortcut needs to be added to KDE.

This may just be a Skype issue, open up kamoso and see if the webcam works.

Studying the page with things about the Asus. Not sure yet how to add the shortcut but hope to figure that out.

The Kamoso does not open. It tries to start (spinning) and then disappears again. Does this mean something not right with Kamoso or that when it does not see a cam it closes?

Oops sorry, I forgot that kamoso hasn’t been ported to use baloo yet.

Here is what you need to do for it to open:

sudo ln -s /usr/lib/ /usr/lib/
sudo ln -s /usr/lib/ /usr/lib/

Thans so much, that solved the kamoso not starting. Now it starts but does not find any cam…
Which would suggest it’s not the problem of Skype but of the camera not being recognised or turned on.
As it worked on the same computer with Open Suse the camera itself must be fine.

I have been reading about keybindings the last hour but not much wiser…

Is there no command to turn the camera on without yet using the key bindings?

Please post the output of lsusb so i can tell which webcam you have.

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Does not look like it is there…

Must be turned off completely, check your BIOS settings.

Very strange, I don’t find any option in the bios to turn it on or off.
I went one by one through all the options but did not see it.

I also tried Kamoso booting Netrunner from the USB stick but same result.
Shall I try Open Suse again and see if it still work there. (I’d have to download a life image)
Do you think that somehow the camera broke? or are there other possibilities?

Yes, boot a live suse image and see if the camera works. If it does run lsusb there so we can figure out what webcam you have.

Thanks so much! I’ll have to do this later and let you know.