What happened to yaourt?

Yaourt Not showing in Octopi tree anymore.

Yep, have the same. Plus that I can’t actually launch octopi without kdesu on one of my PCs. Some small weird things going on…

It’s now the alien head button next to the search bar instead of a fake group in the list.

Ahhh I see as I Love Aliens! Thanks


The idea there is since applications installed from the AUR are not officially supported, they are considered to be alien applications. :wink:

Hmm, my octopi mystery plot thickens.

On my desktop PC were octopi works it has the alien button, on my laptop were I have to use kdesu to run octopi it is not there? I assume it is due to using kdesu to run it as the same things happens to my desktop octopi when i use kdesu to run it.

Another thing I discovered while trying to fix octopi is that when I uninstalled it (with pacman) the various icons associated with it in the application launcher did not disappear, I had to remove them manually and when I installed it again they did not appear in the application launcher?.

There has been some progress though. Previously when I started octopi from command line I didn’t get any feedback and it went straight back to my prompt. Now at least I get something like this:

[code]Time elapsed obtaining Unrequired pkgs from ‘ALL group’ list: 170 mili seconds.

Time elapsed obtaining Foreign pkgs from ‘ALL group’ list: 319 mili seconds.[/code]

However, on my desktop PC i get:

[code]Time elapsed obtaining Unrequired pkgs from ‘ALL group’ list: 170 mili seconds.

Time elapsed obtaining Foreign pkgs from ‘ALL group’ list: 319 mili seconds.

Start local event loop…
Time elapsed obtaining pkgs from ‘ALL group’ list: 231 mili seconds.
Time elapsed setting outdated foreign pkgs from ‘ALL group’ list: 232 mili seconds.
Time elapsed iterating over all pkgs from ‘ALL group’ list: 328 mili seconds.
Time elapsed seting the list to the treeview: 341 mili seconds.
7971 pkgs => Time elapsed building pkgs from ‘ALL group’ list: 540 mili seconds.[/code]

So it is getting stuck on my laptop and doesn’t go forward to the “Start local event loop…”

Is it something in the Qt5 libriries I could be missing, or something with permissions?

The octopi process starts and pops up in the system monitor and the octopi notifier works it will just not open up in a window unless kdesu is used…

Sounds like you may have a pacman lock or corrupt database::

sudo rm /var/lib/pacman/db.lck
sudo pacmsn -Scc
sudo pacman -Syyu

now re-install octopi:

sudo pacman -S octopi octopi octopi-notifier-frameworks octopi-pacmanhelper octopi-cachecleaner octopi-repoeditor

Hi again AJSlye and thanks once more for your suggestions. However, this didn’t work either, didn’t even have the /var/lib/pacman/db.lck.

I think I am done trying to fix ocotpi, don’t really need it and I haven’t come across any other program were its window is refusing to launch, so it seems to affect only ocotpi. However, I do have a question, what would be the reason when installing/unistalling octopi, that the icons for it would not be added/removed from the kicker/launcher, as the program does get installed?

Also removing the octopi and everything else octopi related my shuting down has speeded up, or should say has gone back to how it was.

Because one more thing I noticed after the same upgrade that broke octopi, was that the shutdown became slower. Before the update as soon as I clicked on the shutdown button the desktop would turn black and switch off, after the upgrade though it took a considerable amount of time before the desktop became black, thought I had missed to click the shutdown button. Another funny symptom of the octopi problem…

I could say for sure what is going on with your laptop system, this could be any number of things.
I think something may have went terribly wrong when either updating your system, or something you may have done or an application you installed may have changed something that is causing your issues.

Personally I would try backing up your home directory and doing a fresh install on that system following my guide here:

On a side note: If you wish to migrate from KDE SC 4 to using Plasma 5 follow this guide afterwords:

I finally managed to fix it. I restored my system from my usb stick backup, uninstalled octopi notifier and anything else octopi related, and then did the update from the command line instead, now octopi works. I got the feeling that somehow the notifier had something to do with it, but I don’t care to try and reproduce it…

Sounds good.

I think that maybe the mirrors that were used when you did the update at that time we’re not completely synced yet, so something was missing and didn’t get installed. I have to suggest looking here for the status your closest mirrors prior to doing updates in the future: http://repo.manjaro.org/

Also use rank mirrors periodically to make sure that your using the fastest mirrors possible:

sudo pacman-mirrors -g


I’ve been having the same problems as platon91 and the suggested fixes haven’t work. I also for some reason installed kdesu.

My current state is this:

  • I can run octopi with “sudo octopi” tried installing something and it worked.
  • however, When I did install something I got

error: could not open file /var/lib/pacman/local/clutter-gst2-2.0.14-1/desc: No such file or directory


OK, if you are using KDE SC 4 then the default packages for Octopi to work properly should be:
octopi qt5-base qt5-declarative kdebase-workspace xterm gnome-keyring and yaourt.

If you need the notifier in the tray, repoeditor and/or the cache cleaner then install only these packages:
octopi-notifier-qt4 octopi-pacmanhelper libnotify qt4

octopi-notifier-qt5 (for LXQT and other non QT4 based systems).
octopi-notifier-frameworks (for Plasma 5 use only).

I’m running KDE 4.16.4; To my knowledge I haven’t done anything to my system except doing the updates. I know I haven’t done anything plasma related.

Everything is installed except for kde-workspace, when I try to install it I get:

sudo pacman -S kde-workspace error: target not found: kde-workspace

I’ve also tried the

sudo pacman-mirrors -g sudo pacman -Syyu

I don’t know what it is or why I lost it if I ever had it, but should I try to install “clutter-gst2”

$ pacman -Q clutter-gst2 clutter-gst2 2.0.14-1