Why does Netrunner 13.12 seem to take so long to log in?

I recently noticed that my hard drive was not passing smartmontools tests and so I copied my old Linux installs from the old 750 GB disk to a 500 GB disk that I had lying around, but at the same time, I figured I’d add a new 120 GB SSD to the box and install a bright, shinny new Linux to it for a grand total of 4 distros. I have a little OCD, or I’d just use a single distro at a time on a machine.

On the older “new” 500 GB spinning drive I have:
Debian stable i386 (which started life as Mepis Lenny 8.x but has pretty much been stripped of Mepis & is straight Wheezy with tons of extra packages).
Bodhi i386 based on Ubuntu 12.04 (I quickly decided I didn’t like Enlightenment, so it is KDE4)
Debian SID development i386, it started life as Sidux 2008-1. but is updated and recent.
On the 120 GB SSD I just have Netrunner 13.12 AMD64.

I chose netrunner for the SSD because it is showy & new, I wasn’t expecting it to be a speed demon, but I’m a little disappointed by how long it takes to go from the display manager to the desktop compared to my old, crufty installs on a much slower drive. Netrunner gets to lightdm just fine compared to the other distros. All numbers are seconds. The other distros use KDM for a display manager, FWIW.

NETRUNNER on SSD: 16 (Plymouth breaks up to show a CIFS error but my network shares are mounted normally anyway from the fstab)
Debian Sidux Sid: 33
Debian Stable (was Mepis 8.x): 33
Bodhi 12.04: 45 (it seems to do a fsck, something seems wrong since the transition to the new disk, I had to disable the floppy controller in the BIOS to get it boot up at all, but once it gets past that point it seems fine).

But Netrunner is considerably SLOWER going from lightdm to the desktop then the others, even with XFCE, which I installed when I saw how long it was taking KDE to show up on the desktop. This is despite the fact that netrunner is configured to start an empty session while the other systems tend to be configured to start several programs that I normally use (pidgin, konsole, file manager, browser, whatever). Also, in the past I was much more cavalier about installing all kinds of extra packages even if I never use them or they are only suggested or recommended by apt-get, the Netrunner install is pretty clean.

Netrunner 13.12:
KDE: 40
XFCE: 21-22

Sidux/sid Debian:
KDE panels showing up: 15
KDE all my programs materializing: 25

Bodhi/Ubuntu LTS:
KDE: 16
Enlightenment: 7

Mepis 8.x/Debian Wheey:
KDE: 30
XFCE: 3-4 seconds

Do I need to configure Netrunner to use my SSD? Once Netrunner is up and running it seems responsive, but I’m surprised who long it takes. Also, it doesn’t go to sleep properly, but I haven’t taken a look at that problem, so I do a fresh boot every time. Maybe I can get Netrunner to hibernate and it will come back from the dead more quickly, but the install is only 1 day old.

My machine is not very new, something I cobbled together by myself, I use the Nvidia proprietary driver on all partitions.
AMD Athlon™ X2 Dual Core Processor BE-2300 @ 1.9 GHz
On netrunner cpuinfo reports it to be: cpu MHz : 1000.000, I haven’t tried that on the others.
NVIDIA Corporation G96 [GeForce 9400 GT]
5 GB of DDR2 RAM

Does anyone else have slow login times?

Can you check again the time to desktop with turning off (Setting the Splash Screen to “none”) in System Settings -> Workspace Behaviour?

About the same, I’m afraid. I’d already changed the splash screen, the WelcomeSplash didn’t float my boat (I liked the lightdm pic and splash for the last version of Netrunner better). Moreover the slow login times also occur on XFCE, though it is substantantially faster (though still MUCH slower than in Bodhi or “Mepis”).

I tried a couple of approaches to hibernation and couldn’t get the system to restore from hibernation with either uswsusp or swsusp though I didn’t really try to troubleshoot either.

I was thinking maybe it was Steam or the Web Accounts stuff, but I don’t see them in htop/ksysguard. And I am not a gamer, so I’ll probably never start up Steam. Memory usage is pretty high, FWIW in KDE, 1.1 GB (though I have 5). As usual Firefox is the hog, though I only have about 15 tabs open and FF does not start by default with a new session, so that can’t be it. I have an untouched 11GB of swap (which I won’t use since hibernation isn’t working so I disabled the swap partition on the old drive in fstab). CPU usage seems to bounce between 6-12% on both cores when I’m just staring at htop.

At this point I am beginning to Saucy may be the issue, though a cursory web search doesn’t reveal much evidence that others are having slow login times. I started installing 13.10 after it came out, figuring that a jump from 13.10 to 14.04 would be easier then going from 12.04 (most of my machines) to Trusty Tahr when the next LTS is released in Spring. . I have a couple of other 13.10 installs on computers and while I’m not unduly impressed they seem OK (except for a driver issue on my 6-core machine with HD78XX graphics). I’m not seeing a lot of programs installed from the Netrunner PPAs that would account for the slow login times, particularly in XFCE.

BTW, what is unique about the Firefox build from the netrunner repo? It is at 25, a tick behind the Ubuntu verson. VLC is an updated version compared to the repository version, that I can see.

Netrunner FF build has KDE filedialog and mimetype handling built in.
When upgrading to non-KDE FF 26 and you notice the differences.

I’m not sure that is worth the trade off for being a couple of versions back, FF26 vs. 28. I may just install Firefox Mozilla Build.

Anywho, as to the speed issue, I may have been too hasty entirely blaming Netrunner, it appears that my specific SSD (Kingston V300) is well known for being very pokey, not much faster then a 7200 RPM spinner like my old hard drive. Also, this machine has a rather old mainboard (GA-MA69GM-S2H, 5-6 years old), so it has the older standard 3Gb/s SATA ports, so I’ll try it in a newer build and see how it does. The machine I’m building will not be any faster in CPU speed (well, 9% faster, but 22% of the energy), but will use the later SATA2 spec, so it should be a good test on that front, anyway.

This may help if you are using pulseaudio. I was waiting 10-15 seconds for pulse to start.
I found this link: http://linuxadvantage.blogspot.com/2013/01/kde-rather-slow-to-start-pulseaudio.h
As it says I renamed “pulseaudio.desktop” and cut a GOOD 15 seconds off my log-in time.
Now pulse comes right up and my times are as good as my other two distros.
If you are using pulseaudio, give it a try.