back to Netrunner | back to Blue Systems

Wifi failes to connect


Since I updated from 19.01 to 19.08 my wifi connecting is not working proberly. After every second or third booting it doesn’t connect to the router. The networkmanager is telling “connecting” but it can’t establish.

On board is a Intel Corporation Centrino Advanced-N 6205 card.
“modprobe -r iwlwifi ; modprobe iwlwifi” says that iwlwifi is running.

What can I do to fix this problem?




Does not connect at all or drops out of connection?

Make sure to have the package firmware-iwlwifi installed. You can also try grabbing a newer package version from unstable or experimental of that package as it only contains binary blobs.


Thanks for your reply.

Every second/third booting it does not connect at all and the latest firmware-iwlwifi is already installed.




Then maybe the driver itself has an issue which is fixed with a newer kernel.
You can try installing the newer linux kernel 5.3 from buster-backports.
Activate buster-backports in synaptic or by adding
deb buster-backports main

Then install the packages

After installation reboot the system to use the new kernel.

Hopefully that works for you.



thx for the reply. As proposed, I installed the newer kernel but I’m not quiet sure if it has been successful. Systemsetting is telling me netrunner 19.08 Indigo and kernelversion 4.19.0-6-amd64 (?).

deb testing main contrib non-free

deb ./

deb-src ./

deb stable contrib non-free main

deb buster-backports main

Nevertheless, after rebooting the connection with wifi failed. With the next rebooting the connecting succeeded.




You have installed the two packages and after reboot it is still using 4.19 instead of 5.3?

Are you sure those two packages got installed?


Hello and thank you for your reply.

Meanwhile my system is using the kernel xx5.3.

But there is no improvement with the wlan connection. Almost every second booting it does not connect to wlan at all. Sometimes even the wlan is not shown in the list of possible connections. To click in the kde network manager for connecting fails also. And in the most cases the rebooting helps but this is very annoying procedure.




No idea at all?




I am running out of ideas to be honest.
However you can try maybe this what is listed here:

So far I did not find anyone else describing the issue that you have though.


nevertheless … thank you.

I have always the feeling, and it’ s only a feeling, that the system doesn’t catch always by booting that there is wifi-card. This may be the reason why there is sometimes no wifi-connection at all in the kde network manager. And there have to be at least more than 10 wifi-routers in the neighbourhood …




Just to be sure it is not a dodgy wifi on/off switch causing this?


I checked the wifi on/off switch and it looks pretty well.

I also checked it with the win7-os on this machine four times and I didn’t had any problems. Always the connection has been established.

The i tried it with a netrunner 19-08 live dvd and … no connection possible. Then I checked it with an other wifi-router. No connection.

The next time i started the notebook with netrunner i had a wifi-connection. Rebooting … no connection …
It’s the same game, every third or fourth time it works.

And now? Have to buy a new notebook? :slight_smile:




I can feel your frustration.
It is definitely a bug. But from everything you told me so far I can only assume its a bug in the kernel or some network-manager setup.

Have you tried another linux distribution with the same kernel and level of network setup like KDE Neon for example?
Do you experience the same issue there?