back to Netrunner | back to Blue Systems

Window Title Bar Title absent or flashing


#21

I only changed it once, and the issue hasn’t returned so far. :crossed_fingers:
I wish I could replicate you specific problem, if it returns I’ll investigate deeper.


#22

Well, things might change but my initial experience is that the window titles have straightened themselves out after this last large update.
The initial window placement is still split between both monitors and at a random size, though I don’t know if that’s the case for every application. Clementine seemed to work properly, but then it starts minimized in the tray and when it’s opened from there behaves properly. Firefox and Dolphin are split screen and random sized.


#23

Well, after boot-up today I can say that the title bar flash is back. It had seemed to disappear even through reboots but as I type this in Firefox it’s flashing away.
Okay. Real-time breaking news here. As I was composing this message I thought I’d take a screenshot to illustrate what’s happening because it’s only a portion of the title that’s affected. When I opened Spectacle to do this the problem disappeared as soon as I clicked on ‘Take a New Screenshot’ and it stayed gone after closing Spectacle. So I just tried opening Dolphin and it had the problem (while Firefox was still fine) and I tried to screenshot it but the same thing happened; it cleared up as soon as I clicked ‘Take a New Screenshot’ (Spectacle is set to take a shot of the window under cursor, on click, so I never did take a screenshot I only clicked the button in Spectacle).
Opening a New Instance of Dolphin gives a window with the issue present even while the existing instance of Dolphin is not showing the problem.
These symptoms seem to fit with the pattern of the problem disappearing after switching OpenGL versions. The version of OpenGL doesn’t matter, it’s the reloading of it that seems to clear the issue. Something similar, but not exactly the same, must happen when I click the button in Spectacle to take a new screenshot; the problem disappears in the window on the screen and I’ve just checked but it doesn’t clear the problem on windows on other desktops. So there’s a clue at least; reloading OpenGL clears the problem for all current and future windows in that boot session but the button in Spectacle clears it only for windows present on the current Spectacle desktop. If I had an understanding of how Spectacle worked I might be able to help debug this more but unfortunately I don’t so all I can do is try to give comprehensive reports.
Let me know if there’s anything I can do to help out with this.
Thanks


#24

Just another note on this for future troubleshooting.
After booting up this morning I was using the Guulag Chrome browser and everything seemed normal. It wasn’t until I opened another program (Signal) that I noticed the problem was evident. I’m guessing that the Chrome window doesn’t use the native theme (or something like that) so it wasn’t affected whereas Signal does and so it was affected. I think you probably get my meaning but I’m sure that you have a much better understanding of the matter.


#25

Could it be that the kwin_x11 process is missing? So it might crash?
Chromium/Chrome has the tendency to crash kwin_x11 with nvidia proprietary drivers.


#26

Yes, I also noticed this issue returned after a reboot this morning. I’m not sure what is going on, but it still seems like a kvantum / themeing issue. On my other machine that is not using kvantum at all, I have yet to have this issue. And yes, both systems are the exact same make, model and configuration (HP 24-g227c).

@leszek,
I’m having this same issue on both my Intel only hardware, and on my one and only non-intel, AMD based laptop, so it can’t be an nvidia driver issue.

NOTE: Chrome/Chromium would be using GTK (gtk2, gtk3-classic), and not Qt5/KF5.


#27

Just another note on this topic. This morning when I booted up the problem was present. Instead of reloading/switching the OpenGL I thought I’d try changing desktop settings. I changed Look and Feel and also Theme, both of them more than once, but the problem persists. So I’d guess that the problem lies in the loading of OpenGL or something related to that and not the theme. I noted earlier that invoking Spectacle fixed the problem, but only on that specific desktop, so Spectacle must be doing something with the rendering pipeline for that desktop that changes it; perhaps it’s adding a pipe and reloading it? I’ve no idea how that sort of thing works.
So there another piece of the puzzle. I think I’ll reload OpenGL now and get things back to normal.
Thanks!


#28

Another update.
This time I selected the OpenGL version that I wasn’t using but then cancelled that before applying because I thought I’d try something else.
I switched Tearing Prevention to ‘Full Screen’ and the problem disappeared. It also stayed gone when I switched it back to ‘Automatic’. So I’m guessing it’s reloading the driver or something, similar to when changing OpenGL versions. Once again it seems to point to something being missed or not loading properly or out of order on the initial go-round and then doing it right when it’s reloaded due to a settings change. Just my two cents, and it’s Canadian money so it’s pretty much worthless; take it for what it is, free opinions. :stuck_out_tongue:


#29

When changing look and feel, did you click “use layout from theme”?

You might try not using kvantum: go into systemsettings, plasma tweaks, widget style, and change the application style to something else.


#30

Hmm. I rebooted just now and the problem was not happening. I opened the Display / Compositor window and noticed that the Tearing prevention was still on ‘Full screen repaints’. Maybe this fixed it? I’ll leave it with this setting and see if the problem reappears. I know that there have been other times that the problem didn’t appear even with stock settings so it might be a fluke this time too, but I’ll see.
As for changing from kvantum, It was set on ‘Breeze’ already from my earlier tests and it still is, so maybe that’s what’s actually fixed it. Now I’m running Breeze Dark and Breeze Alpha Black.