Netrunner Home

Window Title Bar Title absent or flashing


#1

Recent install of Rolling 19.04 that’s up to date; running default settings but with dual monitors (1 @ 16x9 1080p and 1 @ 4:3, with the desktop expanded across both)
Like the subject line says, the block that the window title is displayed in blacks out or flashes, though it happens only randomly. I’ve noticed that if I move the mouse over the window control buttons (max, min, kill) the flashing stops and the title is displayed properly, but moving the mouse away allows it to resume.
Not much else to say about it but I can supply more information if requested.
OpenGL driver R600G
Thanks


#2

Definitely something wrong with the driver.
Can you check inix -G to see which driver is in use radeon or amdgpu


#3
[crankey@HPPCL ~]$ inix -G
bash: inix: command not found
[crankey@HPPCL ~]$ ls /usr/bin/*inix*
/usr/bin/fsck.minix  /usr/bin/mkfs.minix
[crankey@HPPCL ~]$ ls /usr/sbin/*inix*
/usr/sbin/fsck.minix  /usr/sbin/mkfs.minix

[crankey@HPPCL ~]$ dmesg | grep radeon
[ 8.686187] [drm] radeon kernel modesetting enabled.
[ 8.686296] fb: switching to radeondrmfb from VESA VGA
[ 8.687516] radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[ 8.687517] radeon 0000:01:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[ 8.687649] [drm] radeon: 1024M of VRAM memory ready
[ 8.687650] [drm] radeon: 1024M of GTT memory ready.
[ 9.132876] [drm] radeon: dpm initialized
[ 9.166597] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[ 9.188073] radeon 0000:01:00.0: WB enabled
[ 9.188082] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0x000000003fd294dd
[ 9.188088] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0x0000000090bb381e
[ 9.188865] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0x000000004ff2aab8
[ 9.188877] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[ 9.188969] radeon 0000:01:00.0: radeon: using MSI.
[ 9.189021] [drm] radeon: irq initialized.
[ 10.203982] fbcon: radeondrmfb (fb0) is primary device
[ 10.203986] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[ 10.228933] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
[ 18.292115] radeon_dp_aux_transfer_native: 74 callbacks suppressed
[ 68.602160] radeon_dp_aux_transfer_native: 74 callbacks suppressed

[crankey@HPPCL ~]$ dmesg | grep amdgpu
there are no results for this command


#4

That was a typo, it’s inxi -G


#5

[crankey@HPPCL ~]$ inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Barts PRO [Radeon HD 6850] driver: radeon v: kernel  
          Display: x11 server: X.Org 1.20.4 driver: radeon FAILED: ati unloaded: modesetting tty: N/A  
          OpenGL: renderer: AMD BARTS (DRM 2.50.0 / 4.19.36-1-MANJARO LLVM 8.0.0) v: 3.3 Mesa 19.0.3


#6

Now, that concerns me.

What is the output for mhwd -li

PS, you could also look under system settings > hardware detection.


#7

[crankey@HPPCL ~]$ mhwd -li
> Installed PCI configs:

                 NAME               VERSION          FREEDRIVER           TYPE

          video-linux            2018.05.04                true            PCI
        network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!
[crankey@HPPCL ~]$


#8

It looks like the kernel module failed to load so the ati driver unloaded, leaving you using the modesetting driver.
What does system settings > hardware detection show?
Do you have a hybrid setup?


#9

I’m not sure what you mean by a hybrid system but I do have a dual monitor setup. One is a 16x9 Samsung LED and the other is a rather old Dell 4x3. I’m assuming that the 16x9 is running at 1080p and I don’t know what the 4x3 is running at, but objects on each seem to be about the same size. The two monitors are being used as a single extended desktop and seem to work fine the way they were setup by default during the installation.

I have posted another issue on here about windows not moving between virtual desktops when commanded to do so. Perhaps these two issues are related?


#10

OK, I read this line wrong.
The radeon driver is the kernel driver and it is in use.
However, the ati (xorg driver) failed to load, and the modesetting (xorg driver) was unloaded.

I would check your xorg.n.log files under /var/log/ like this:

Note: check both LoadModule and UnloadModule lines.


#11

[crankey@HPPCL ~]$ cat /var/log/Xorg.0.log | grep oadModule
[    15.158] (II) LoadModule: “glx”
[    15.341] (II) LoadModule: “radeon”
[    15.384] (II) LoadModule: “ati”
[    15.389] (II) LoadModule: “modesetting”
[    15.390] (II) LoadModule: “fbdev”
[    15.391] (II) LoadModule: “vesa”
[    15.398] (II) LoadModule: “fb”
[    15.405] (II) LoadModule: “dri2”
[    17.569] (II) LoadModule: “glamoregl”
[    18.550] (II) LoadModule: “ramdac”
[    18.550] (II) UnloadModule: “modesetting”
[    20.070] (II) LoadModule: “libinput”
[crankey@HPPCL ~]$

[ 15.396] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 15.396] (II) [KMS] Kernel modesetting enabled.
[ 15.397] (WW) Falling back to old probe method for modesetting


#12

hmm,

[jamesk@james-pc ~]$ cat /var/log/Xorg.0.log | grep oadModule
[105197.030] (II) LoadModule: "glx"
[105197.033] (II) LoadModule: "intel"
[105197.034] (II) LoadModule: "modesetting"
[105197.035] (II) LoadModule: "fbdev"
[105197.036] (II) LoadModule: "vesa"
[105197.057] (II) LoadModule: "dri3"
[105197.057] (II) LoadModule: "dri2"
[105197.057] (II) LoadModule: "present"
[105197.057] (II) UnloadModule: "modesetting"
[105197.119] (II) LoadModule: "libinput"

Update: I’ve noticed this same behaviour on some of my fresh installs, especially with older graphics chips.
It’s seems to be a compositor issue. Go into System Settings > Display > Compositor and change the rendering backend to a different opengl setting ( aka opengl 2.x to opengl 3.x, etc.) and click apply. You can always change the opengl backend setting back again if you experience any other issues.


#13

Well, I opened the System Settings window and fortunately it had the wonky title bar happening, and when I changed from OpenGL 2.0 to OpenGL 3.1 the problem disappeared as soon as I hit ‘Apply’. I’ll (obviously) keep an eye on it but I’m guessing it’s fixed.

Any feedback on my other post about being unable to move windows between virtual desktops?
Update: Dolphin window behaves properly. Spotify window still ignores commands to change desktops.
Thanks!