Windows and Netrunner Dual Boot Installation

Forgive me if this has been addressed before but I have a HP Desktop with four (4)
CPUs, two 500 GB harddrives, and a GeForce video card with 4 MB of ram. I have Windows 7 on drive 0 and reserve drive 1 for Linux. I have successfully installed Zorin OS, Mint 14, Ubunto, Ubunto Gnome etc. at one time or another and after installing (prior linux versions removed prior to installation) these distributions always gave me a grub menu to choose what I wanted to boot. But not with Kbuntu or Netrunner. They never seem to “see” Windows 7 when installing and after installing on drive 1 and rebooting, I get weird results, sometimes a command line grub and other times a grub without showing Windows 7. Because of this I am running a very tweeked version of Mint 17 instead of Kbuntu or Netrunner 14. I have Netrunner on an old lenova R60 laptop with 3GB Ram and a 500mb harddrive and it runs very well. I also have a Dell Desktop with only one harddrive but have the same problem when trying to install Kbuntu or Netrunner with a dual boot option (It has Vista on the first partition)… again Ubuntu etc will install without a problem but not Kbuntu or Netrunner. Anyone have a simple fix to this major (in my opinion) installation problem? Thanks in advance.

The question is if you have an uefi or bios system ?
Was there any error message during installation ?

Normal bios system. No error messages at all. It asks how you want to partition and I use the default guided installation which leaves the NFTS partition alone. I haven’t a clue why the dual-boot is so easy with Mint, Ubuntu, Lubuntu, etc but not so with Kbuntu and Netrunner. Thanks.

That’s really strange as it uses the same installer.

Actually the installer is similar but looks different in structure. I have installed various Linux distros, Ubuntu, Lbuntu, Zorin, Linux Lite, Ultimate Linux, LXLE, Mint 17,Bodhi, and others and have only had the problem installing Kbuntu, Netrunner, and Fedora who seem to have the same basic installer, yet is different from the one used by Ubuntu. Because I have tried to install Netrunner on two different desktops (a HP and a Dell, both having very up to date hardware) I think there is a problem when trying to install a dual-boot. If I didn’t have to have this Windows to program three different Logitech Remotes (No support for Linux from Logitech, and they don’t care about Linux) I would likely dump windows…Concordance is a poor replacement to program different remotes. So there you have it. I hope someone will look into this problem and maybe there will be an easy fix.:angel:

From the technical standpoint it is the same ubiquity installer but it uses a slightly different ui (qt4 based)

Yup, but technically it doesn’t do it. I hope others will try to dual boot and report on it. Thanks.:angel:

:rolleyes: The solution was not too difficult. Originally I was installing off a usb flash drive and had the failures. I burned a 64 bit DVD last evening and was able to install the dual boot without difficulty. You need to be sure you don’t over-write the NFTS partitions Windows is located on, of course. I mention this because it doesn’t tell you that you can install it along side Windows like the Ubuntu installer. But it works fine now, and I have replaced Mint with Netrunner on my Desktop. I like Netrunner better for a number of reasons, one of which is it doesn’t have too many programs preinstalled for me. I prefer to install what I want after the installation. Another for me is it is easier to apply themes that totaly work (it was not always so possible in Mint.) Anyway, PROBLEM SOLVED!

Thought I’d chime in here since I’m currently trying to switch over from openSuse to Netrunner. I set up a Dualboot on my Laptop. Netrunner is a joy to use and runs fine, but everytime I try to boot Windows7 from the bootmanager I get no visible login screen. The Startup sound is there and I seem to be able to log in, but nothing on the screen. Anyone got similiar Problems?

EDIT: I am a silly stupidhead and should not confuse wireless drivers for graphics drivers. With the proper drivers installed both OS work like a charm.

I too had a problem with dual booting Win 8 and Netrunner. At first I thought I had lost grub when I changed my win8 from ssd to reg drive and got a grub error. I used a grub cd to start my system every time since.It found my operating systems no problem but if I used it to reinstall grub no luck. I recently installed Netrunner rolling (latest release) via dvd and no errors reported. Upon restart no grub again, same problem. Tried to reverse order of win drive with netrunner drive, re-installed and same thing. I never had this problem prior to the last releases of netrunner. I won’t give up on them but am currently using another distro. am using 64bit and have been using linux since 1999. This is the first major thing I have come across since I started using Netrunner. Oh it worked fine on my HP netbook dual booting with Win 7 (previous rolling release). Guess Billy G added some script in win 8 to prevent real operating systems from being used.

I am no expert, but I can report that I have been running Netrunner and Windows 7 in a dual boot with zero problems–and yes it does give me the grub selection menu up front. The menu does allow me to select Netrunner or Win7. Like you I have tried all the popular Linux distros and seem to have settled in with Netrunner 14. Linux Mint KDE would be my second choice–both are great distros and both work very well. RIght now I give Netrunner the edge.