Wireless driver install

So I’ve been having issues installing a wireless driver. I have and netgear AC1200 usb adapter which has the mediatek mt7612u chipset. I tried installing the driver using the install disc with wine, but that didn’t work so I tried to install the driver using ndiswrapper but wifi didn’t show up using ndiswrapper even though the driver was installed and the hardware was present. So then I found the chipset and and downloaded the drivers for it (http://www.mediatek.com/en/downloads/mt7612u/ ) but I had to make them, so when I ran the command make I popped up the error: make *** [LINUX] error 2 and I have no idea what that means. I attached the driver .tar

I digged a little bit for that chipset. And its in reality a Ralink 2870 that should be supported out of the box.
Before you do anything please remove all attempts of ndiswrapper first.

Then did you check out the driver manager if it shows something regarding the usb wireless stick (if it is plugged in) ?
You can also try manually loading the rt2870sta driver and see if it works with it by entering

sudo modprobe -v rt2870sta
In a terminal.

Ok so i did remove the driver I used with ndiswrapper and when I did look at the device manager only my graphics card showed up but when I did an lsusb it picked up my usb adapter. Also there was a module failed error when I tried to modprobe the rt2870sta. Could it be that it just isn’t installed or something else?

Can you post the error output.
The rt2780sta driver should be there by default as kernel module. So no need to install it.

“modprobe: ERROR: could not insert ‘rt2870sta’: Exec format error” I just got this one when I tried to manually install the driver. Before hand according to modprobe rt2870 didn’t exist on the system

[quote]“modprobe: ERROR: could not insert ‘rt2870sta’: Exec format error” I just got this one when I tried to manually install the driver. Before hand according to modprobe rt2870 didn’t exist on the system
Thats the problem. I don’t know how you manually compiled or installed the driver but it doesn’t seem to be compatible with your kernel. Please remove the driver again and use the official coming with the kernel.
If it does not work anymore, because you overwritten the shipped driver, then please reinstall the kernel with

sudo apt-get install --reinstall linux-image-`uname -r` .
Or simply use synaptic for this. And retry loading rt2870sta not rt2870

Ok so I removed the driver, re installed the kernel and rebooted for safe measure. I then tried to modprobe the driver again and I got the error code that I was receiving the first time.

 modprobe: FATAL: Module rt2870sta not found.

So it looks like this driver/chipset isn’t compatible with the kernel or it isn’t built it. Mind you I’ve tried using this same usb device across two other distros with no luck.

This error simply means that the rt2870sta driver is not installed. Thats strange as I thought it would come with the kernel. Seems like it doesn’t.

What does the command

locate rt2870
show you. Are there any other rt2870 drivers already installed ?

rt2870 shows up as in the /lib/firmware folder as rt2870.bin and thats it. Nothing else.

And sudo modprobe -v rt2780 does work or does it throw an error aswell ?

yes, same one as before.

 modprobe: FATAL: Module rt2780 not found
 modprobe: FATAL. Module rt2870 not found

(just in case you were referring to both)

Iam out of ideas now. Seems like the Ubuntu base is not shipping the driver anymore.
The only thing I found regarding this problem and self compile is this thread: https://answers.launchpad.net/ubuntu/+question/255620

dang I was hoping for an end for the 4 day problem

It is a problematic chip as it seems. Usually atheros chips work directly out of the box and best as far as my experience goes. So there is always the easy solution buying some atheros based wifi dongle :slight_smile: (ath5k or ath9k compatible ones is what I recommend)

Although I’m trying to do it again with ndiswrapper and I’m taking a look at the .inf files and in it, it says needs netvwifibus.inf. Could that be an issue that I should also include that .inf file which I did see when I tried to look for the actual driver in device manager in windows. Also when I run ndiswrapper and try to install I get the message:

couldn't find models section "Ralink" - installation may be incomplete

Yeah I guess you need that inf file aswell.

Unfortunately adding the wifibus didn’t work, but I think it has something to due with the missing models section “Ralink” unfortunately I have no idea how drivers work so I don’t want to add something that I don’t know about.