Wireless hard block

Hi all, I’ve been running Netrunner for about a month now. I have a few issues and haven’t seen them in the forum yet. Up front, thank you for reading and any information is greatly appreciated. I am running a Satellite L655 AMD Athlon II P360 64 bit 2GB RAM. Completely wiped and reformatted, Netrunner 12.12 is ONLY Operating System. Occasionally my wifi goes out, no light, no connection. RFKILL shows soft block no, hard block yes. Sudo rfkill unblock all has no effect. I’ve also run the fixes from other sites i’ve seen, but they don’t work either. The thing about this laptop is, there isn’t a hard wifi switch. I have a function key and a windows key on the keyboard. FN+F8 is suposed to turn my wifi on and off, but my function keys don’t work. If I was running Windows7 I would be able to control it with Toshiba Center but I don’t have that on Netrunner. I wish my FN keys worked :(. Anyway the only solution that has worked for me so far is shutting the computer down, then removing the RAM for a few seconds. When I restart, wifi works. Does anyone know a better fix?

have a look at this. It sounds like the same problem: http://ubuntuforums.org/showthread.php?t=1790306
Hope that helps.

Hey that worked! You are a saint. Thank you!